dual boot PLUS root on A5IT PLUS all done in windows

Special Developer Edition Firmwares and Hacking on Archos 5 IT, 5/7 IMT, 605/705, with Android, ├àngstr├Âm and other Linux
Post Reply
Archos Novice
Archos Novice
Posts: 1
Joined: Fri Apr 15, 2011 9:14 pm

dual boot PLUS root on A5IT PLUS all done in windows

Post by bobnagga »

So Whatup, yall? Everywhere I've looked, they say you can't set up the dual-boot and root under windows... I did it last night. I was researching this thing for over a week, and even contemplating taking it to a pawn shop if I couldn't root it. I wasn't about to install Linux on my PC just to do it, either.

So I got to thinking: "Why do we need Linux on a PC if there's Linux in a little tablet in my hand? It didn't make sense, so I started playing in the root shell on Angstrom... Did you know that the X-window file manager won't let you copy stuff to root, but you can do it in the shell?

That's beside the point because I was reading the instructions wrong... anyway, I used ext2ifs to mount the drive under winXP and it worked for me. I can't find aostools for windows, and I think that's the issue here. Everything else CAN be done under windows. I ought to try to compile the AOStools under the angst rom and see what happens... Nobody's tried this before?

Whatever the case, I used the froyo dual (Triple?) boot instructions with the donut firmware from this guy's post:


rather than using the regular archos firmware. Beware, though, lots of things won't work on this version, Archos Media Center being the most notable. That's really no big loss (At least to me), but apparently the File Manager uses "media center features" which are "unavailable for now. Try again in a few seconds." ... o_O

How am I supposed to install SetCPU and autostarts if I can't even access the SDCard? No big deal, the browser still works, so I went to download this thing called AndExplorer. Since the download manager AND package installer still work, it loaded fine and I now have access to the entire thing...

What else? My device is no longer registered with Archos, I have to use third party software for bluetooth pairing... BUT I have 120MB free memory now! HA! The firmware version comes up as "null(android 1.6)"
I tried to just copy HTC's senseUI into the ext2 partition and update the boot.lst... It didn't work... I may have to go back and do the froyo install again, but replace the alpha2.img with HTC's boot.img.

I don't really care all that much about SenseUI in and of itself, I just had the rom kitchen laying around from my Hero, so this is more in the nature of an experiment to see if it works. All I'm really worried about is having to download andexplorer again when I flash the updates... Maybe I can leave the openaos/update directory empty and it will leave archos' firmware alone whilst flashing the sense UI? Guess I'll find out.

Let me know what you guys think!
Archos Novice
Archos Novice
Posts: 9
Joined: Sat Apr 14, 2012 7:22 pm
Location: West Des Moines, IA

Re: dual boot PLUS root on A5IT PLUS all done in windows

Post by BartHD2 »

Cool post first off... I've got 2 Archos 5 it's and am wanting to tinker around with most exactly what your doing.. however not a programmer.... any thoughts or walk-thru steps to get started!!? Excited and like how your thinking outside the box!

Thx again.
A7 160g
A5A 2.0.38
A5A 2.0.45
Post Reply

Return to “Open Development”