Wireless issue.connected to router and network no internet..

8" 4:3 1024x768 capacitive, OMAP4460 Dual-core, 3G-optional tablet.
Post Reply
Archos Guru
Archos Guru
Posts: 513
Joined: Sun Dec 09, 2007 11:59 pm
Location: Melbourne, Australia

Wireless issue.connected to router and network no internet..

Post by Agj_h »

Solved this but was a frustrating problem for a while. Posting in case other users get this issue.

Had the archos 80 gen9 for over two years now and it's been a great little tablet which is still in daily use.

However, around a week ago the tablet stopped fetching internet content. This was strange as there was no change to the router (linksys e4200) or any other parts of our home network and all of the (nearly) hundreds of other devices around such as ipads, iphone's etc had no issues.

The symptom was that it would connect all ok to the router as usual but no internet content could be fetched via any of the browsers or play store, other apps etc.

Reset the tablet back to defaults and reloaded firmware - no change.

The strange thing was that I could still browse all of the local network shares and stream videos etc from these shares - it was just the internet side of things not working.

Very frustrating.

Tried a few different things and one of the things that did kindof work was turning on and connecting to the 'guest account' function on my router. Once this was done I was back to surfing the net. All good except this wasn't really a viable solution as the guest account feature does not allow you to connect to network shares so could not stream videos etc. I didn't want to have to muck around with disconnecting and reconnecting to each of the routers SID's depending on what I wanted to do.

After this I tried changing the wireless settings on the tablet to a static IP address. This worked fine so problem solved but still don't know what went wrong in the first place. Additionally, the wireless settings to change to static address are not very intuitive. There are fields that have default values in them but that are greyed out so gives the impression that these cant be changed whereas they can be (and should be).
500gb a5a
G9 80 16gb 4.0.28
Post Reply

Return to “Archos 80 G9”