Page 1 of 1

Archos 101 G9 simply won't mount

Posted: Tue May 08, 2012 1:00 pm
by villaman01

Had my G9 for about a month and on the whole im happy.

However, i simply cannot mount this device with my W 7 PC.

Ive also tried it with my laptop which is XP and the 101 does not prompt me with "Mount".

Ive also tried to connect via WIFI to transfer files (films) but it keeps asking my for a user name and password to access my Shared folder on the PC ?

My son has the 101 G8 and as soon as you put the usb cable in it prompts you with "Mount"

Can anybody please help?


Posted: Tue May 08, 2012 1:20 pm
by Dinosaur
Your G9 is running Android version 3.x (or possibly 4.x if you have updated it) while your son's 101 G8 is running one of the Android version 2.x series - probably 2.2.x (Froyo) or 2.3.x (Gingerbread).

Versions 2.x and 3.x connect to the PC in a different manner. Version 2.x comes up with the prompt asking whether you want to "mount" or not, whereas your Archos 101 G9 doesn't - it just connects anyway!

On your PC, open My Computer and you will see the 101 G8 in the section "Devices with Removable Storage" and it will appear as 1 or 2 devices, depending on whether there is an SD card in the device or not.

On the other hand, your 101 G9 will show in the section "Other" as "ARCHOS 101G9". Double-click on this icon and a new Windows Explorer window will open showing 1 or 2 devices (again depending on whether there is an SD card in it or not) called "Internal Storage" and "SD Card". Double click on either of these to see the contents.


Posted: Tue May 08, 2012 1:32 pm
by villaman01
Hi there Dinosur,

Thank your very much for your reply and help.

Ive looked in My computer and also in the Device manager, ive also scanned for new hardware, but alas my PC does not see it.

I have indeed upgraded to ICS and the very latest FM update.

Ive been on this for about the last 3 hours looking around for a solution but to no avail.

My PC see all othewr USB devices that i put in, ive ever tried a different port, but it just does not see it ??

Thank you again for your help


Posted: Tue May 08, 2012 3:46 pm
by bhmm
You need the latest windows media player. Also see alternatives solutions in the below thread and the thread referenced within.



Posted: Tue May 08, 2012 4:28 pm
by Dinosaur
I don't use either Windows Media Player 11 (although I do have it installed, maybe that makes a difference?) or AirDroid from market as that other thread suggests. I just connect my 101 G9 to my PC (Windows XP Pro, fully up-to-date) and the 101 G9 appears as per my previous post.

There is an interesting comment in that other thread - "- use the small USB (not the 3G one)". That is very true, I'm surprised that anyone ever tried connecting that way!! You certainly would not be able to connect to the 3G port using the USB cable that comes with the G9!!

Villaman - I take it that you are using the Archos USB cable that came with your G9? If not, use it - that's why it came with your G9!! Ofc, using that cable would rule out any possibility of attempting to use the 3G port, since the cable is normal USB2 at the PC end and microUSB at the Archos end.

If you are using the correct cable, then we've got to start looking at where the problem lies - could be any of:

    1. Windows Media Player 11
    2. PC
    3. Cable
    4. Archos

Let's look at these in sequence.

    1. Do you have Windows Media Player 11 installed? If not, install it!
    2. The PC. You say that you can use other USB devices on your PC/Laptop, so that one is ruled out.
    3. The Cable. Do you have any other device that you can connect to the microUSB end of the cable? My Samsung phone also has a microUSB port and works on the Archos cable.
    4. The Archos. Do you have any other device that you can plug into the microUSB port? I have a USB 2.0 A Female to Micro B Male adapter which allows me to attach other USB devices to the G9. (I typically have a real keyboard plugged in.)

Let me know how it goes.

btw - I am still using 3.2.80, so ICS is not a pre-requisite


Posted: Fri May 11, 2012 6:53 pm
by villaman01
May i thank you both kindly for replying so quickly and for your help.

I, as a temporary measure, download a wifi file transfer app, but i ordered a nerw USB to Mini USB cable which turned up today and guess what....

yes it appears to have been the old cable i was using.

i think it might have been my wifes Blackberry cable DOH !

Thank you again fvor your help, and i did learnt something...the wifi file transfer app is great and pretty handy.