Page 2 of 2

Re: OpenVPN configuration in 2.2 froyo on Archos

Posted: Mon Jan 17, 2011 6:36 pm
by AvengerMoJo
I add the ca.crt with the p12 file still not working ... I use --tls-auth as well.
Cipher algorithm DES-EDE3-CBC size default
Not sure what is wrong and still not working... just don't get a good way to debug ... when I get root in the command line before updating the firmware it work... so it get to be the configuration problem... really hope they can fix this..

Re: OpenVPN configuration in 2.2 froyo on Archos

Posted: Tue Jan 18, 2011 3:18 am
by AvengerMoJo
I don't really know what happen, but I did put in the 192 cipher size and it is working now .... they really need to provide better debugging or log for user to read... it is not windows man .... it is linux! :)

Re: OpenVPN configuration in 2.2 froyo on Archos

Posted: Tue Jan 18, 2011 3:22 am
by AvengerMoJo
So thanks a lot jhendry, I think combin the ca into the p12 help as well. Thanks Sauron for the steps. Now I can finally get online without using other vpn router ... driving me crazy :) I'm in China.

Re: OpenVPN configuration in 2.2 froyo on Archos

Posted: Fri Jan 21, 2011 4:04 pm
by neooray
I have an 101 too but it doesn't import any Certs, P12. I merged die Key and the the Cert, copied to sd but still says "no Certifcate found" - runs on 2.0.71 :cry:

Re: OpenVPN configuration in 2.2 froyo on Archos

Posted: Fri Sep 16, 2011 11:18 pm
by afen
AvengerMoJo wrote:I don't really know what happen, but I did put in the 192 cipher size and it is working now .... they really need to provide better debugging or log for user to read... it is not windows man .... it is linux! :)
Am currently battling to configure Archos OpenVPN client on my A43 IT, with firmware 2.4.19 (and as yet have been unsuccessful).

However there IS a way to make the client generate a log file which can then be used to help in debugging. Add the following to the Extra Arguments field in the OpenVPN advanced settings

--log /path/to/logfile

In my case, the internal 16GB storage is mounted as /mnt/storage, so my argument reads:

--log /mnt/storage/openvpn.log [or whatever filename you want to use as a log file]

Hope this could be of some help

regards

afen