Page 1 of 1

Problem installing ADB driver

Posted: Sun Aug 25, 2013 5:16 am
by pwnedu46
I downloaded the ADB driver from the downloads page, however it says the hash for the file is not present. I've tried re-downloading and re-installing several times over both WiFi and over an Ethernet cable and got the same error every time.

I had no problem installing the driver on my desktop (Win7) several months ago, could this be a problem with Windows 8, or just a bad download link?


Screenshot:
Image

Re: Problem installing ADB driver

Posted: Fri Nov 29, 2013 6:51 pm
by IByte
The Archos USB driver for ADB worked fine for me on Windows 7, but I haven't been able to install it on Windows 8.1. I keep getting the "missing hash" message from Windows. I mailed Archos support about it about a week ago, but they haven't responded yet. The USB driver bundled with the Android SDK doesn't appear to do the trick either.

Does anyone else know how to connect the Archos to ADB on Windows 8.1?

Re: Problem installing ADB driver

Posted: Thu Dec 12, 2013 12:47 am
by IByte
I finally got the Archos ADB driver to work on Windows 8.1. To achieve this, I turned off driver signing enforcement in Windows (not ideal, but it does the trick). The instructions on how to do this are here:

MSDN: How do I turn off the the Secure Boot policy or allow modifications to values protected by it so I can turn on Test Mode?

This allowed me to install the Archos ADB USB driver on Windows 8 and ADB is now working fine with my Archos 80 G9. There is still no word from Archos Support on when or if they are going to properly sign their driver in order to support Windows 8.