need help: archos70 went blank and won't start!

7" capacitive, $199 for 8GB, $249 for 250GB (with free shipping), HDMI output, webcam...
Post Reply
abby
Archos Novice
Archos Novice
Posts: 7
Joined: Thu Jan 12, 2012 10:59 am

need help: archos70 went blank and won't start!

Post by abby »

hi. having problem with my archos 70. it just went black and won't start. i tried recharging, after nearly 16 hours, the light still won't blink. what should i do? i'm new to this product. please help....
paulus3476
Archos Guru
Archos Guru
Posts: 1206
Joined: Mon Apr 09, 2007 8:03 pm
Location: Lincs,UK

Re: need help: archos70 went blank and won't start!

Post by paulus3476 »

You need to post more information - model info, is it 8gb or 250gb, what were you doing with it prior to it going blank, was it in use, have you ever used it or is it new. if it's new and it doesn't appear to be charging, the battery may have died because of cold temperature - move it into the warmest room in your house and allow it to charge for a few hours, then try again to swith it on.
FZelle
Archos Guru
Archos Guru
Posts: 653
Joined: Tue Nov 30, 2010 6:07 pm

Re: need help: archos70 went blank and won't start!

Post by FZelle »

And if it's the firsttime you try to charge be sure to use the lower plug, as the upper one is for headphones.
abby
Archos Novice
Archos Novice
Posts: 7
Joined: Thu Jan 12, 2012 10:59 am

Re: need help: archos70 went blank and won't start!

Post by abby »

i've already been using it for a week. it's 8gb. it was still ok when i was using it yesterday until i recharge it. then it went blank. after awhile, i tried to start it. but it just won't start.
paulus3476
Archos Guru
Archos Guru
Posts: 1206
Joined: Mon Apr 09, 2007 8:03 pm
Location: Lincs,UK

Re: need help: archos70 went blank and won't start!

Post by paulus3476 »

Can you tell us what happens if the charger is not plugged in, is there a green light ? Have you tried holding down the power button for 30 seconds, then press once to see if it starts ?
abby
Archos Novice
Archos Novice
Posts: 7
Joined: Thu Jan 12, 2012 10:59 am

Re: need help: archos70 went blank and won't start!

Post by abby »

there's no light at all if the charger is not plug in. nothing happens when i press the power button for 30 seconds, then press one to see it starts. i mean yes, i did try what u told me but nothing happens.
Smooch
Archos Novice
Archos Novice
Posts: 6
Joined: Wed Jan 11, 2012 4:04 pm

Re: need help: archos70 went blank and won't start!

Post by Smooch »

Mine did the same, try this it worked for me (mine was an A70b), I looked for the manual on the website and it said:

- If the charging indicator does not blink after few seconds, it could mean that the battery is over discharged.

1. Plug out the power supply.
2. Press 10 seconds on the On/Off button for a hardware reset. (it was suggested longer by others on the forum so I did)
3. Plug in the tablet to the power supply.
After a certain period (few minutes or one hour), the charging indicator starts blinking.

it took 30mins after plugging it back in for the light to come one and took over 12 hours to charge just like the first time. It now charges normally.
abby
Archos Novice
Archos Novice
Posts: 7
Joined: Thu Jan 12, 2012 10:59 am

Re: need help: archos70 went blank and won't start!

Post by abby »

well, i did tried what you told me to do. but after plugging in the tablet to the power supply, the charging indicator light turns on, and does not blink at all.
paulus3476
Archos Guru
Archos Guru
Posts: 1206
Joined: Mon Apr 09, 2007 8:03 pm
Location: Lincs,UK

Re: need help: archos70 went blank and won't start!

Post by paulus3476 »

the indicator light blinking indicates a fully charged battery - your battery seems to be over - discharged and so shouldn't blink, but be solid green. I sugest you leave it plugged in to the wall charger - NOT a pc usb port - overnite and see if the green light is flashing in the morning, do not leave it in a cold room as it seems to affect the battery/charging circuit, if that still hasn't worked, then you may have a hardware fault
abby
Archos Novice
Archos Novice
Posts: 7
Joined: Thu Jan 12, 2012 10:59 am

Re: need help: archos70 went blank and won't start!

Post by abby »

ok. will do. thanks.
abby
Archos Novice
Archos Novice
Posts: 7
Joined: Thu Jan 12, 2012 10:59 am

Re: need help: archos70 went blank and won't start!

Post by abby »

it still won't start.....what should i do?
paulus3476
Archos Guru
Archos Guru
Posts: 1206
Joined: Mon Apr 09, 2007 8:03 pm
Location: Lincs,UK

Re: need help: archos70 went blank and won't start!

Post by paulus3476 »

I think you need to go back to where you purchased it from and see about their returns policy, failing that you will have to contact Archos customer support
abby
Archos Novice
Archos Novice
Posts: 7
Joined: Thu Jan 12, 2012 10:59 am

Re: need help: archos70 went blank and won't start!

Post by abby »

thanks for all your advices and help.....
Post Reply

Return to “Archos 70 Internet Tablet”