Page 1 of 5

Losing files on the micro SD card

Posted: Thu Dec 02, 2010 8:36 pm
by Airedale
I keep losing files I put on the micro SD card. I thought it was because I was just pulling the the USB cable without properly ejecting but that wasn't it. I just uploaded about 30 photos through the USB cable, did the eject then removed the USB cable from the A70.

When I checked the files all the new ones were there but many of the old ones had disappeared.

I suppose it could be a bad SD card.

Is anyone else having problems with files disappearing off their micro SD cards?

Re: Losing files on the micro SD card

Posted: Thu Dec 02, 2010 9:35 pm
by paulus3476
That does sound like a bad sd card - is it a large capacity card that you recently purchased from a well known site - if so, most of them are fake. There is a free utility called 'h2testw' which will test the card for correct functionality

Re: Losing files on the micro SD card

Posted: Fri Dec 03, 2010 12:41 am
by AllenPapapetrou
Airedale wrote:I keep losing files I put on the micro SD card. I thought it was because I was just pulling the the USB cable without properly ejecting but that wasn't it. I just uploaded about 30 photos through the USB cable, did the eject then removed the USB cable from the A70.

When I checked the files all the new ones were there but many of the old ones had disappeared.

I suppose it could be a bad SD card.

Is anyone else having problems with files disappearing off their micro SD cards?
Exactly how do you know they are gone?

Do they show on your PC?

Do they show in Files on your Archos?

Allen

Re: Losing files on the micro SD card

Posted: Fri Dec 03, 2010 12:54 am
by eagle1
paulus3476 wrote:That does sound like a bad sd card - is it a large capacity card that you recently purchased from a well known site - if so, most of them are fake. There is a free utility called 'h2testw' which will test the card for correct functionality
Agree with this.!
First, try to troubleshoot if it's the card or not.
It does sounds weird and that's usually behavior on fake sdhc cards!

Keep us posted.

Thanks.

Re: Losing files on the micro SD card

Posted: Fri Dec 03, 2010 12:55 am
by ElementalDragon
paulus: i fail to see how large capacity + well known site = fake. I've purchased my fair share of SD and CF cards from well known sites (mostly Newegg) and have never had an issue with a "fake" card.

Re: Losing files on the micro SD card

Posted: Fri Dec 03, 2010 12:56 am
by viking
paulus3476 wrote: is it a large capacity card that you recently purchased from a well known site - if so, most of them are fake.
Ebay, especially if you got an unbelievable price. They have the ability to address the full range of memory, but not actually store throughout. So strange things happen when you try to retrieve. Almost all of the ebay ones are said to be fake, and they are in fact less than half price.

I wonder if these were intentionally made bad, or are just the rejects from sorting? When I worked in the chip biz, they would throw out 90% or so of the results (for difficult hi perf products) that had microscopic defects - I wonder if somebody is putting those in their pockets instead and reselling?

Re: Losing files on the micro SD card

Posted: Fri Dec 03, 2010 2:03 am
by paulus3476
paulus: i fail to see how large capacity + well known site = fake. I've purchased my fair share of SD and CF cards from well known sites (mostly Newegg) and have never had an issue with a "fake" card.
I was referring to ebay ,of course

Re: Losing files on the micro SD card

Posted: Fri Dec 03, 2010 3:23 am
by chavo12345
test with H2testw and report your findings:

http://www.softpedia.com/get/System/Sys ... estw.shtml

Re: Losing files on the micro SD card

Posted: Fri Dec 03, 2010 5:09 am
by Airedale
AllenPapapetrou wrote: Exactly how do you know they are gone?

Do they show on your PC?

Do they show in Files on your Archos?

Allen
This has happened several times but the most recent was this afternoon.
I copied 60 jpg files to a folder on the SD card then browsed through them in the gallery. I added 4 more files a few hours later. I went back to the gallery and it only showed 4 files. The file manager on the A70 showed the same thing. Connecting with the USB cable and browsing from the PC also showed 4 files.

I ran Recuva on the SD card and recovered about 50 of the original files. It said it recovered all of them but some were corrupted.

I haven't actually lost anything but some time since all the photos are saved on my PC anyway.

I ran h2testw and it wrote and verified 16gb twice with no errors. I did the full, slow reformat of the card before running h2testw. Maybe that was all the card needed.

The card didn't come from Ebay but from a retailer that I've bought a dozen or so memory cards from and never had a problem.

I think this had something to do with the Froyo update. All of my photos disappeared from the SD card when I updated. The funny thing is that the directory structure and all of the Word docs stayed on the card. Only jpg files were deleted.

I backed the card up before updating to Froyo and I just copied all the photos back to the card. I'll add some more files tomorrow and see what happens.

Re: Losing files on the micro SD card

Posted: Fri Dec 03, 2010 1:08 pm
by paulus3476
Good practice is to format the card with the device you intend to use it in - try it and see if it solves the problem

Re: Losing files on the micro SD card

Posted: Fri Dec 03, 2010 4:12 pm
by Airedale
paulus3476 wrote:Good practice is to format the card with the device you intend to use it in - try it and see if it solves the problem
I agree. I just figure out how to do that. I'll do it before I buy another SD card.

This morning I copied 37 more jpg files to the SD card. Those are all there as are 8 of the files I put on the card last night. The other 88 jpg files are gone.

The directory structure and all of the Word documents are still there, which is exactly what happened before.

At this point I guess I have to buy another micro SD so I can determine if the problem is the card or the A70.

Re: Losing files on the micro SD card

Posted: Fri Dec 03, 2010 4:54 pm
by Airedale
After formatting the SD card in the A70, I copied my photos again. There are 143 files in 9 folders.

I ejected the device from my PC and turned off USB sharing on the A70 and removed the USB cable. I verified the file counts in each folder and all was well.

Next I plugged the USB cable back in and transferred 1 jpg file to the folder called models. When I checked the file counts again, all the files from that folder were still there and so was the new file. Unfortunately, 28 files from another folder were deleted.

I'm ordering a new micro SD card today. If the problem persists, my A70 goes back to Archos.

Re: Losing files on the micro SD card

Posted: Fri Dec 03, 2010 7:00 pm
by Airedale
I just put a new sdhc card in the A70 and copied the 144 photo files with the USB cable. I didn't disconnect the USB and checked that all 144 files were there.

Next I copied 1 more file to the Models folder. The new file made it there but 9 files from other folders were deleted.

I've eliminated a bad sdhc card and improperly removing the USB connection from the list of possibilities. Now I will contact Archos support.

Re: Losing files on the micro SD card

Posted: Fri Dec 03, 2010 8:07 pm
by eagle1
WTF?!?!

Does this happen with your other content?
Or just Pictures/Photos?!?

Has anyone else experienced the same thing?
It could be a Froyo induced fault if others are experiencing it! If not, then it could be your unit (which would also make it weird! ;)).

Re: Losing files on the micro SD card

Posted: Fri Dec 03, 2010 8:31 pm
by ViPaSoft
eagle1 wrote:WTF?!?!

Does this happen with your other content?
Or just Pictures/Photos?!?

Has anyone else experienced the same thing?
It could be a Froyo induced fault if others are experiencing it! If not, then it could be your unit (which would also make it weird! ;)).
I copied 9 photos onto the card earlier and used one of them as a wallpaper. Later on I went to look at them again and they were gone. I know the card is ok because I used it for months on my Phone before I bought a new class 6 8Gb card for that.

Haven't noticed any other files going missing, but to be honest I haven't check, but will do from now on.

Re: Losing files on the micro SD card

Posted: Sat Dec 04, 2010 1:00 am
by Airedale
It seems to only be jpg files and only on the SD card. I have some Word documents and Excel spreadsheets on the SD card and they don't seem to be affected. I copied some jpg files into the docouments folder to see what would happen.

Nearly all of the photos I put on the SD card today are now gone. I haven't been able to put my finger on what is causing it. I know it happens if I add jpgs to the card. After I stopped adding jpgs today, I still lost 50 files in just one folder.

I'm thinking about wiping the device and loading Froyo again. I really don't have anything to lose since I don't trust it with anything important anyway.

Re: Losing files on the micro SD card

Posted: Sat Dec 04, 2010 1:22 am
by kavawava
paulus3476 wrote:Good practice is to format the card with the device you intend to use it in - try it and see if it solves the problem
I seem to be having the same problem, loaded up an entire season of a TV show and when i tried opening it up today the folder was still there but the videos were gone.

Bought a 32gb Sandisk from Amazon.

How do I format the SD card via the A70? I tried looking under storage and SD card, but the "Format SD card" option is grey'd out and I can't select it.

Re: Losing files on the micro SD card

Posted: Sat Dec 04, 2010 2:39 am
by Airedale
kavawava wrote:
paulus3476 wrote:Good practice is to format the card with the device you intend to use it in - try it and see if it solves the problem
I seem to be having the same problem, loaded up an entire season of a TV show and when i tried opening it up today the folder was still there but the videos were gone.

Bought a 32gb Sandisk from Amazon.

How do I format the SD card via the A70? I tried looking under storage and SD card, but the "Format SD card" option is grey'd out and I can't select it.
Go to settings then storage. You will need to unmount the SD card to format it.

I have a 16gb Ridata and an 8gb Sandisk. The same thing happens on both cards.

Re: Losing files on the micro SD card

Posted: Sat Dec 04, 2010 2:59 am
by kavawava
Airedale wrote:
kavawava wrote:
paulus3476 wrote:Good practice is to format the card with the device you intend to use it in - try it and see if it solves the problem
I seem to be having the same problem, loaded up an entire season of a TV show and when i tried opening it up today the folder was still there but the videos were gone.

Bought a 32gb Sandisk from Amazon.

How do I format the SD card via the A70? I tried looking under storage and SD card, but the "Format SD card" option is grey'd out and I can't select it.
Go to settings then storage. You will need to unmount the SD card to format it.

I have a 16gb Ridata and an 8gb Sandisk. The same thing happens on both cards.
awesome thank you, lets hope this works

Re: Losing files on the micro SD card

Posted: Sat Dec 04, 2010 10:50 am
by kavawava
Dammit, just happened to me again.

Loaded up 3 movies onto my SD card, confirmed that they were all there. Then later in the day loaded up two more movies and the 3 that were originally on there are now GONE.

Strangely all the movies that are in my internal memory are fine.

UGH, this is so frustrating, anyone have any solutions?