Brand new A43it won't turn on

4.3", $219 for 16GB, HDMI output, HD camcorder...
Post Reply
jpelgrom
Archos Novice
Archos Novice
Posts: 9
Joined: Tue May 03, 2011 12:55 pm

Brand new A43it won't turn on

Post by jpelgrom »

Hello,
I just got a brand new Archos 43 Internet Tablet 2 days ago. Since then, it has been plugged into my computer or a USB charger, and still no progress. It won't boot at all on battery, and on USB it goes like: 'stable green light for 3 seconds - short blink - longer blink - stable green light for 3 seconds - short blink - longer blink - stable (...)'. The screen also doesn't show anything. It shows a really small light when there's a stable green light, but nothing to see. Not even the Archos bootscreen!

To clarify: brand new device, won't turn on, not configured and used yet. Also not being recognized by one of my PCs (Win7 Home Prem. 64bit and WinXP Prof. 32bit).

My question: has anybody expierienced this before? And does anybody know a solution for this problem? Right now, I can't do anything with it... :(
julian67
Archos Expert
Archos Expert
Posts: 218
Joined: Thu Feb 03, 2011 2:33 pm

Re: Brand new A43it won't turn on

Post by julian67 »

Charge it for at least 3 hours, uninterrupted, on PC or laptop connected to mains power, or using a mains adapter. Archos specify to charge for "several hours" before first use. Not 30 minutes or an hour but several hours. In plain English several hours can be taken to mean at least three hours, so be patient and charge it for 3 hours without interruptions or checking. If it still doesn't work then make a warranty claim.
jpelgrom
Archos Novice
Archos Novice
Posts: 9
Joined: Tue May 03, 2011 12:55 pm

Re: Brand new A43it won't turn on

Post by jpelgrom »

Right now I'm at about 48 hours charging...
julian67
Archos Expert
Archos Expert
Posts: 218
Joined: Thu Feb 03, 2011 2:33 pm

Re: Brand new A43it won't turn on

Post by julian67 »

So get your money back or exchange the product.
Post Reply

Return to “Archos 43 Internet Tablet”