Page 1 of 1

An Archos 48 greusome foursome

Posted: Wed Aug 08, 2012 6:55 am
by StarCannibal
I'm not a computer whiz, but I'll describe my problem best I can. Was charging my 48 500GB. Shortly after disconnecting the unit from the USB, I noticed the following:

1. The USB connection icon is always on.

2. The device has an ARC library update partial wakelock.

3. The device is always doing an ARC library update.

4. When I actually connect the device to USB, Windows no longer recognizes it, so I can't add any media files.

This happened about a wk ago, and all 4 persist.
I can remove the wakelock temporarily by using the System Monitor to stop all programs, so I can still listen to music, connect to internet, etc.

Don't know if this is relevant, but I only transfer files manually by copy/past through Windows Explorer (abhor sync), never thru WMP. I have about 200GB of music/videos stored on the 48, all of which were scanned for malware/viruses prior to transferring to the device. I have not added any optional apps.

I think the 48 would be a great piece, but this is my THIRD in just over a year (first one suddenly refused to power up after about 9 months. I rec'd a replacement which never worked, and I've had this one for 4-5 months).

I'm thinking about doing a disk format and just wiping everything out, but it's a pain in the ass and I'm not sure that would be a permanent solution.

This young cannibal would be grateful for any input!

cheers,
SC

Re: An Archos 48 greusome foursome

Posted: Wed Aug 08, 2012 7:03 pm
by eddie32818
StarCannibal wrote:I'm not a computer whiz, but I'll describe my problem best I can. Was charging my 48 500GB. Shortly after disconnecting the unit from the USB, I noticed the following:

1. The USB connection icon is always on.
Try using "safely disconnect usb device" in windows taskbar, when removing (unmounting).

2. The device has an ARC library update partial wakelock.
This is a normal operation, and you let it continue in order for your Archos run more smoothly.

3. The device is always doing an ARC library update.
See above.

4. When I actually connect the device to USB, Windows no longer recognizes it, so I can't add any media files.
Go into your archos.settings and check the "device storage connection mode" and select mass storage device to allow it to connect as an external drive. This is what I use to drag and drop media in mine.

After the ARClibrary finishes reboot your archos.



Re: An Archos 48 greusome foursome

Posted: Wed Aug 08, 2012 9:36 pm
by Cary L. Brown
StarCannibal wrote:I'm not a computer whiz, but I'll describe my problem best I can. Was charging my 48 500GB. Shortly after disconnecting the unit from the USB, I noticed the following:

1. The USB connection icon is always on.

2. The device has an ARC library update partial wakelock.

3. The device is always doing an ARC library update.

4. When I actually connect the device to USB, Windows no longer recognizes it, so I can't add any media files.

This happened about a wk ago, and all 4 persist.
I can remove the wakelock temporarily by using the System Monitor to stop all programs, so I can still listen to music, connect to internet, etc.

Don't know if this is relevant, but I only transfer files manually by copy/past through Windows Explorer (abhor sync), never thru WMP. I have about 200GB of music/videos stored on the 48, all of which were scanned for malware/viruses prior to transferring to the device. I have not added any optional apps.

I think the 48 would be a great piece, but this is my THIRD in just over a year (first one suddenly refused to power up after about 9 months. I rec'd a replacement which never worked, and I've had this one for 4-5 months).

I'm thinking about doing a disk format and just wiping everything out, but it's a pain in the ass and I'm not sure that would be a permanent solution.

This young cannibal would be grateful for any input!

cheers,
SC
Sounds like you're yanking out the USB cable while files are actually being moved back and forth. That's an easy way to ruin your Arclibrary, and mess up your USB connection.

If I'm mistaken... sorry... but it really does sound like what I'd expect if you did that.

I recommend you purge out the ArcLibrary and rebuild it from scratch. If that doesn't help... back up your Archos contents and reformat the drive. And, of course, I presume you've been actually doing a "full reboot" to the machine regularly... ie, totally powering it off, then powering it on again momentarily. If not... that, alone, is often enough to fix some of these issues.

I get the impression that you've managed to corrupt the file system, at some level. But I can't be sure what level it's become corrupted at... the full hard drive level, or just the "ArcLibrary" database level.

Re: An Archos 48 greusome foursome

Posted: Thu Aug 09, 2012 5:42 pm
by StarCannibal
Thank you very much for your quick reply.

I wish that was the reason--if so, I'd know how to prevent it from happening again! I'm very careful about waiting for the "safe to remove" indicator, and I've never had problems with my 2 older portable media players (or Blackberry). Nor was this the issue with my first two 48's (first one just refused to power up, second defective out of the box). I also use BitDefender and Hitman Pro prior to downloading. The file system is definitely corrupted, though. Only difference is that I download some FLAC files (either downloaded as such or converted from WAV with Traders' Little Helper) to the Archos, but not to my other devices. Can't see how that would be the problem, as I've never had problems transferring FLAC to the 48.
Guess me and Archos just weren't meant to be... :cry: