Page 1 of 1

firmware update help

Posted: Wed May 15, 2013 3:18 pm
by ArchosBill
I was given a 120gb archos 5 by a friend, he never really used it so it is relatively new. After it was fully charged, I turned it on and went through the setup process, then at the bottom of the screen it said something about drive needs to be checked (RO). I just figured the firmware was old so i would download the newest firmware update and go from there. It wouldn't ever connect via wifi so i downloaded the update to my PC and then tried to copy that file to the archos. I got the permission denied when i tried to copy the file over so I held the power button and the volume down button and got to the recovery menu. Here I did the recovery or repair (whichever is the first choice after done. There was no change after that so I went back to the recovery menu and formatted the device. I then plugged it back into my PC and was able to copy the firmware file to the archos's hard drive. when i opened the drive there were 3 folders music, video, and one other( sorry I can't remember what it was). I didn't paste the firmware file in any of these folders, I just put I in what i believe to be the root menu.

Anyway this i where i am now, where i need help/suggestions. After copying the firmware file to the device, It recognized the new firmware file and began the installation, now 2+ hours have passed and the installation progress bar has stalled out around 85% complete. What can i do? can i turn it off and try again? will turning it off brick my device? please help...

Re: firmware update help

Posted: Wed May 15, 2013 7:45 pm
by ArchosBill
Anyone have any suggestions I'm still at 85%. Does anyone have any ideas what will happen if it turn it off? Any thoughts, guesses?

Re: firmware update help

Posted: Fri May 17, 2013 10:37 pm
by mediate
It's possible the hard drive's got some weird sector that the firmware is trying to write to. You should, in theory, be able to restart the update if you turn it off. Try an older version, perhaps the same version on the unit. I'm bent on believing that there's a weird sector with the hard drive though, and you'll likely need to do a low level format (READ: This means you will need to remove your hard drive from inside, the battery likely won't last long enough for that) then another archos format, but I'm not sure. Try applying the update again before doing anything drastic though.