installing enlightenment? Issue w/profile select [SOLVED]

Special Developer Edition Firmwares and Hacking on Archos 5 IT, 5/7 IMT, 605/705, with Android, ├àngstr├Âm and other Linux
Post Reply
Spz0
Archos Guru
Archos Guru
Posts: 409
Joined: Sat Jan 12, 2008 7:06 am
Contact:

installing enlightenment? Issue w/profile select [SOLVED]

Post by Spz0 »

I've been working on installing enlightenment on my A5IMT.
The first go around, I installed it just fine. There was a crc error just before the configuring process started in shell, but it completed fine.
I rebooted, and the e17 wizard started up. Got through the language selection screen, and progressed to the profile selection. There were no profiles to select, so I was stuck there, unable to go anywhere further.

So, I reloaded a fresh img of angstrom and investigated..
The crc error is happening somewhere within "efreet" or one of its dependencies.
Im not sure if this is the issue of nothing showing up in the profile selection, but deductive reasoning would say "maybe".

Has anyone successfully installed e-wm, or have they run into this issue as well.
Any possible solutions?

Any help would be greatly appreciated!!! :)

Thanks in advance!!
Last edited by Spz0 on Sun Mar 07, 2010 2:53 am, edited 1 time in total.
www.openAOS.org
Spz0
Archos Guru
Archos Guru
Posts: 409
Joined: Sat Jan 12, 2008 7:06 am
Contact:

Re: Any success installing enlightenment? Issue w/profile select

Post by Spz0 »

Im a dork... I didn't install any profiles.....
problem solved. lol

If you are going to install enlightenment, make sure you install the profile:
e-wm-config-angstrom
and optionally:
e-wm-config-illume

just list | grep e-wm and you'll see all the config profiles there.

cheers.
www.openAOS.org
joethc
Archos Novice
Archos Novice
Posts: 7
Joined: Thu Mar 04, 2010 5:33 am

Re: installing enlightenment? Issue w/profile select [SOLVED]

Post by joethc »

Ive tried out a couple themes myself this thread opened the door to what i was looking for thanks Spz0 for this thread .I keep going back to illume tho, the shelf is really functional for switching desktops. All the other themes I have tried don't have the functionality. Also I totally lose mplayer when in E. It just wont load. Ive removed e-wm to see if that was the issue and it is....any ideas?
Spz0
Archos Guru
Archos Guru
Posts: 409
Joined: Sat Jan 12, 2008 7:06 am
Contact:

Re: installing enlightenment? Issue w/profile select [SOLVED]

Post by Spz0 »

I have that issue as well with the Mplayer, and I haven't figured out why yet. Im going to be looking for an alternative player. There is another media player that GPE installs by default, which I've used for mp3's. Its a pretty basic player but works well.
Illume is really nice, but whats not nice is the qwerty keyboard. the auto-complete keyboard would be great if it just wouldn't auto complete. lol. The standard keyboards keys are too small, due to them trying to cram too many keys on the screen.
Im using the angstrom theme myself (I've altered the font/icon sizes to make it a bit more touch friendly). I want to test out that illume theme more, to see if I can make some alterations. Mainly the font sizes in the shelf (the "illume" text, the config button, and the qwerty keyboard button).
One thing I don't like so far, is that there is no left/right click distinction in e17. Some programs allow you to tap and hold for right click, but e17 doesnt (ie: trying to right click the desktop, or right click a gadget on the desktop, etc...)

Glad This post helped you m8. :)
Cheers!!
www.openAOS.org
TheRain
Archos Novice
Archos Novice
Posts: 18
Joined: Fri Feb 12, 2010 1:55 am

Re: installing enlightenment? Issue w/profile select [SOLVED]

Post by TheRain »

Very cool- I've been trying to get E with illume up and running as well and hadn't discovered this. Will have to try this some time today.

Have you guys had success with getting other things working?

I'm planning to start a Wiki for what I'm working on- a Games and Media oriented linux image for Archos5IT.
So far I have-
- OSS Sound working
- OpenGL ES working and playing nice with X11

working on:
- USB Gamepad (trying to get USB OTG working)
- Fixing touch screen repeated touch up/down events
joethc
Archos Novice
Archos Novice
Posts: 7
Joined: Thu Mar 04, 2010 5:33 am

Re: installing enlightenment? Issue w/profile select [SOLVED]

Post by joethc »

Just curious to which media player do you refer to for playing mp3s ? Starling is the only media player I see installed aside from mplayer. It just flashes the top bar at me, no settings or anything to be seen ...maybe I am missing something. I also agree with you illume does need a bit of switching to be more effective but as soon as I saw desktop switching ....sold. Being able to utilize the machine a little better goes a long way in the end. Just wait soon someone will have mythtv and bluetooth gps working. I personally want video out as well and I am investigating into it further.
joethc
Archos Novice
Archos Novice
Posts: 7
Joined: Thu Mar 04, 2010 5:33 am

Re: installing enlightenment? Issue w/profile select [SOLVED]

Post by joethc »

I also just noticed that the tango gps is missing as well when using e.
TheRain
Archos Novice
Archos Novice
Posts: 18
Joined: Fri Feb 12, 2010 1:55 am

Re: installing enlightenment? Issue w/profile select [SOLVED]

Post by TheRain »

@joethc:

For video out, here is some really thorough documentation of the omapfb driver that should be pretty helpful to that end (you maybe already have this
http://groups.google.com/group/beaglebo ... c614622053

This is the same that is used in the Android distribution that comes with the Archos5IT. I'm hacking around with this in android as well, in order to get native applications (read emulators) access to fast direct blitting.
joethc
Archos Novice
Archos Novice
Posts: 7
Joined: Thu Mar 04, 2010 5:33 am

Re: installing enlightenment? Issue w/profile select [SOLVED]

Post by joethc »

Thanks for that I have been trying to get my pico projector to work under sde for a bit now. I kinda thought the original avos would be key to get it working and looking at that the output is there already. You guys rock !!!!! I am no means a developer but I do try to help out where i can.
TheRain
Archos Novice
Archos Novice
Posts: 18
Joined: Fri Feb 12, 2010 1:55 am

Re: installing enlightenment? Issue w/profile select [SOLVED]

Post by TheRain »

Hey Spz0 - would you be willing to share your whole .bb image file?

I'm still having no luck getting this going and I'm really interested in trying it. Are you using the release/2009 branch of OE?

cheers,

Collin
Spz0
Archos Guru
Archos Guru
Posts: 409
Joined: Sat Jan 12, 2008 7:06 am
Contact:

Re: installing enlightenment? Issue w/profile select [SOLVED]

Post by Spz0 »

Im using the 2008 release of e17.
PM me your email address and I'll be happy to send you my image file. :)
www.openAOS.org
Post Reply

Return to “Open Development”