libc dilemma

Special Developer Edition Firmwares and Hacking on Archos 5 IT, 5/7 IMT, 605/705, with Android, ├àngstr├Âm and other Linux
Post Reply
cuse
Archos Novice
Archos Novice
Posts: 15
Joined: Sat Jan 09, 2010 11:46 pm

libc dilemma

Post by cuse »

I tried to bitbake some arbitrary simple C app (e.g. nano) with openembedded for the Archos 5 angstrom distro, the build succeeded but I cannot install the resulting .ipk package with gpe-package, because the resulting .ipk package has a dependency to libc >=2.9, whereas the official angstrom firmware for the Archos 5 just has libc 2.6 installed.

I tried to force my host OE installation to setup an environment with libc 2.6, but I get an error message "requested version not available" and then the OE host falls back to libc 2.9 again.

I also tried to upgrade libc on the Archos 5 with a libc 2.9 .ipk package built on my OE host, but installation with gpe-package fails, since libc has a cyclic dependency to another app.

How can I solve this libc version problem? Do I have to hack the meta files in the .ipk packages to force gpe-package to accept the packages? Should I install a command line alternative to gpe-package? How did you guys solve it?
generic_username
Archos Expert
Archos Expert
Posts: 194
Joined: Mon Jan 14, 2008 9:18 pm

Re: libc dilemma

Post by generic_username »

sry not a gen6 owner, but, is it not possible to specify which version of libc to use as a bitbake command arguement?
serbor
Archos User
Archos User
Posts: 79
Joined: Thu Nov 27, 2008 11:39 am

Re: libc dilemma

Post by serbor »

There is a PREFERRED_VERSION_glibc ?= "2.6.1" environment variable set up in angstrom-2008.1.conf

If you have got `2.9` then it means that you didn't set up your configuration correctly.
cuse
Archos Novice
Archos Novice
Posts: 15
Joined: Sat Jan 09, 2010 11:46 pm

Re: libc dilemma

Post by cuse »

Setting PREFERRED_VERSION_glibc ?= "2.6.1" did the trick!

I actually used that macro and set it to PREFERRED_VERSION_glibc ?= "2.6" before, but I got the mentioned error message that no matching glibc version could be found and then OE fell back to the youngest glibc version instead. Seems specifying the 3rd digit makes the difference.

Thanks!
serbor
Archos User
Archos User
Posts: 79
Joined: Thu Nov 27, 2008 11:39 am

Re: libc dilemma

Post by serbor »

That's strange.
I mean that this particular version has been set up by default and there is no need to mangle with this variable.

It looks like you have misconfigured system.
cuse
Archos Novice
Archos Novice
Posts: 15
Joined: Sat Jan 09, 2010 11:46 pm

Re: libc dilemma

Post by cuse »

I just grabbed OE with git 2 days ago, and PREFERRED_VERSION_glibc was definitely set to "2.9", the comment above it was still saying "2.6.1" though, so probably it has been changed recently. But whatever, it works now.
Post Reply

Return to “Open Development”