Archos 704 TV problem and Firmware Request

7" 800x480
Post Reply
Archos Novice
Archos Novice
Posts: 2
Joined: Thu Dec 04, 2014 10:57 am

Archos 704 TV problem and Firmware Request

Post by markpsych »


Recently purchased one of these by accident, i.e., thought it was a standard 704 and then found the digital tv icon.

Initially very pleased, as plugged in the aerial set from my old av700 and it fired up and scanned perfectly....but keeps randomly restarting and returning to the home screen (usually after about 1 minute, but sometimes works for long periods with no problem)?

Have also tried with the home tv aerial, and same problem :-(

Similar problem to this: only appears far more random and not restricted to 2 channels.

Tempting to suspect the digital technology is simply out of date....but the older av700 tv model still works perfectly.

Have tried the factory reset, and the firmware is 1.7.53, which google suggests is the latest?

Archos don't appear to offer any support for any of these older models now, so wondered if someone here may be able to help, and perhaps confirm if I do have the latest firmware?

Shame, as the unit is immaculate and every other function appears to work 100%.

Post Reply

Return to “704 WiFi and 704 TV”