Page 1 of 1

Archos FamilyPad 2 : changing MAC address

Posted: Thu May 23, 2013 9:58 pm
by DaveM
I'm getting hopeless with that issue.

I bought a FamilyPad 2 because I am pretty interested by its 13.3" screen. My goal is to use it at work to be able to check my mail when flying from meeting to meeting. To be able to connect to our BYOD dedicated WIFI network, I gave the MAC address of the tablet.

As I was not able to connect, I investigated and discovered that the MAC address of the tablet was changing after each reboot!!!!!!!

I reported the problem to Archos support. They asked me if I was not looking at the IP address instead of the MAC address.
I answered that being an IT engineer with 24 years of experience, I was able to make the difference between a MAC and an IP address. I explained them :
- where I was looking the MAC address info in the tablet's settings;
- that in fact the 6 first digits of the MAC address (the manufacturer id) were not changing, but digit 7 tà 10 well (network card
serial number)
and gave them examples of MAC address after several reboots, and asked if there was no existing patch.
Archos asked me to send the tablet back. I did it. Some days later, I got back a brand new tablet with exactly the same problem.

So I guess my only solution is to spoof the MAC address to the desired value. To do that, I need to root my tablet.I tried several rooting tools and installed several ADB USB drivers. No way.

In this scope, my questions are :
- is there somebody who has experience in rooting a FamilyPad 2 tablet?
- or is there somebody who knows about a bugfix for the MAC address change.

An if not, I'll go for a 13.3" tablet of a competitor.

Thanks in advance.

Re: Archos FamilyPad 2 : changing MAC address

Posted: Thu May 30, 2013 9:44 pm
by DaveM
I tried to root my tablet with OneClickRoot, Doomlord's zergRush, Archangel. No way!

No answer to my post.

Seems like my weird situation is hopeless. :cry:

I give up. I will go for a tablet from the competition. :(

Re: Archos FamilyPad 2 : changing MAC address

Posted: Sat Jun 22, 2013 5:53 pm
by clbgld

Was searching the net for posts on this tablet and ran across yours. I can confirm that the unit I have also exhibit this behavior. That is really a *very bad* bug!!

There doesn't seem to be many choices out there at the moment at this size/pricepoint. I have the Kocaso M (GX) 1400 as well, which does have bluetooth, unlike the Familypad, (cannot understand Archos' decision to not include bluetooth on the Familypad2), but it has its own quirks as well. The units look almost exactly alike and obviously have the same base board in them as well as screen, except for the bluetooth hardware (that is, assuming the lack of bluetooth is a hardware issue and not a lack of firmware suppot).

I have not found a stylus that works well with either unit. Obviously the sensitivity of the touchscreen is set too low (too many pixels need to be triggered to register the touch).

Like you, I have not been able to find any way to root the familypad. the Kocaso was very easy to root.


Re: Archos FamilyPad 2 : changing MAC address

Posted: Sat Jun 22, 2013 8:57 pm
by viking
Does the kocaso also vary the mac address?

Re: Archos FamilyPad 2 : changing MAC address

Posted: Sat Jun 22, 2013 10:49 pm
by DaveM

Than your for your post. I thought I was the only one.

Yes indeed, it's a strange behaviour. And on this issue, Archos Support really sucks!!! Anyway, I was able to get it working at work. But As i can't go through the ACL, I have to log in every time I want to go on Internet #-o .

I looked at the competition. I found two 13.3" tablets that looks exactly like the Archos one, taking into account that archos seems to have the best finishing. These tablets are :
* Yarvik Xenta 13c ( ... TAB13-201/);
* Odys Aeon 13.3" (
You can get them from Amazon.

Samsung just released a 13.3". But it's Windows 8. So => $$ or €€.

I didn't use any stylus.I Prefer my finger :shock: . I will make a test with the ones I use at work for the industrial touch panel PCs I'm deploying.

Ac the Family Pad 2 is dedicated to family use, you will not find any decent ADB driver or programming supporting the firmware for rooting purpose. If only Archos could solve that bloody bug.



Re: Archos FamilyPad 2 : changing MAC address

Posted: Sun Jun 23, 2013 4:48 pm
by clbgld

Actually, there is a new unit which is slightly smaller but with better specs all around, the Icoo 12GT. My work has ordered one from tabletsprint and I can't wait to try it out. Since resolution is higher, one might be able to use the stylus.

Will check the other ones you mention, but they should be similar (if not the same) as the Kocaso.

I see that Archos still has the January firmware posted on their site. Guess they are not in a hurry to fix the MAC address issue...

All best,


EDIT: The ones you mentioned don't seem to be available in the US very easily. Also, no mention of Bluetooth I could find.

Re: Archos FamilyPad 2 : changing MAC address

Posted: Sun Jun 23, 2013 4:54 pm
by clbgld
So far, it has not.
viking wrote:Does the kocaso also vary the mac address?

Re: Archos FamilyPad 2 : changing MAC address

Posted: Wed Jun 26, 2013 7:47 pm
by DaveM


My last post was not recorded.. Strange? Anyway it was just to says that indeed
* the Yarvik and Odys tablet have no bluetooth. Bluetooth is not a criteria I was taking into account. But, why not?
* I got this tablets on

I put a post on Yarvik's forum asking them to confirm me that they have no MAC issue. The moderator sent me to a post on their site : ... ter-reboot.



Re: Archos FamilyPad 2 : changing MAC address

Posted: Wed Jun 26, 2013 8:49 pm
by viking
So yarvik had the problem, then released fixed firmware...

Re: Archos FamilyPad 2 : changing MAC address

Posted: Thu Jun 27, 2013 9:55 pm
by DaveM
Let's hope Archos will follow the same way...
Bets are open. ;)

Re: Archos FamilyPad 2 : changing MAC address

Posted: Mon Nov 18, 2013 9:36 pm
by AmarilloTX
How to ROOT Archos Familypad 2

I have tried many posted solutions and then even started looking into making a modified boot image until I finally came across a simple 1 click method. Cost me between 50-100 hrs of research and my personal time so I hope its appreciated by you.

STEP 1: ESTABLISH ADB Driver connection (skip part A if you can do this by yourself)

Part A) This can be a heart breaking experience on this particular device. I am an electrical engineer (msee degree) and I have never had problems getting the correct settings and setting up an ADB driver. But this device busted my butt. SO, to make it easy for you, and for me, download the PdaNet application (PdaNetA4126.exe) - a program called PDANet (used normally to allow you to wired tether your phone’s internet to your computer) can be used to install the ADB drivers for a lot of phones. THEN, on your Archos Familypad, turn on USB debugging, plug into computer, and start PDANet and follow it’s instructions.

Part B) VERIFY ADB: In command prompt, type "adb devices". YOU WILL SEE YOUR ARCHOS DEVICE! You can now safely delete PDANet on computer and on your Archos - we don't need it anymore. If you do not know how to get ADB or how to use ADB then STOP ROOTING YOU DEVICE NOW since you have much to learn and read before you start messing with rooting.

STEP 2: Download: ""
see: ... ?t=1886460

NOTE: Be careful not to install and malware or other programs from any download sites, just get the zip file ONLY. MUST have version 31!

Unzip, run, select option 1, and presto...... YOU HAVE ROOT !!!!!!

STEP 3: Download from play store "Root Checker" or your own preferred root checking app and see the results.

Even if you restore FACTORY SETTINGS you will still have root! Yea baby!!!!!!


Also posted on:
Title: ROOT Archos Familypad 2 - How to - IT WORKS !!!
Posted On: xda developers web site
Posted by User: AmarilloTX (that is me)

:D :D :D :D :D :D :p :p :p :p :p :p :o :o :o :o :o :o

Re: Archos FamilyPad 2 : changing MAC address

Posted: Sun Feb 01, 2015 8:52 pm
by tiziano958

Hallo to everybody.
I have the same MAC problem on my very new tablet ARCHOS 101 Copper. This means that ARCHOS maintains years long his error on the firmwares.
But how is possible to change the MAC????
Has anyone found a solution?