Page 1 of 1


Posted: Tue Sep 23, 2014 10:39 pm
by Remdale
!!!Downgrade from 1.6.53 to 1.1.06+UNLOCK BOTH PLUGINS!!!

Guys, I did it!!I have 2 of archos 504. The first one was with "undowngradable" bootloader and the 1.6.53 firmware, which is the biggest problem for people who want to change a Hard drive. The second one is with an old bootloader and has 1.1.06 version of installed firmware. I've copied the 1.1.06 hidden partition and installed the image to 1.6.53 HDD. Then I've copied 1.2.05 firmware file into the newly created 1.1.06 drive and started upgrade. After that the first player started to accept other ide drives. That's all. The player is free from lock.
I've found something else about plugins on the first player. If you downgrade the firmware to the lower version, the player stops to recognize videos which need plugins. It says to buy plugins. But if you again upgrade to the version where the plugins are supported, then they start to work.
Someone told that the newest bootloader rejects trying to make a record into it. Not in this case, I guess.
So don't be afraid to upgrade to the newer firmware to use plugins. But I recommend you to not upgrade the bootloader. Accidents happen. Just create an image of 1.6.53 and start to downgrade the bootloader. Then just use "HD Clone" software to install 1.6.53.

Take out the hard drive and connect it directly to PC through ide adaptor.
Run "HD Clone"->Restore partition->choose the folder where 1.2.05 image is located: first click on the needed drive from the left panel. Then using the right panel go to the folder with the needed image folder and click on it-> click Next (if the button is not active, it means you didn't choose the image)->in the next window "Target partition" click "Show all partitions" to uncover the hidden partition->find the hard drive of your Archos and click on the smaller partition called "unnamed". Its size has to be around 97MB->click Next->Start->Start copying->(Waiting)->Automatically->Quite HDClone.
Place the hard drive back into Archos and start it. Choose "repair" if recovery menu appears. Then use 1.7.16 firmware file to downgrade the bootloader.
You're DONE!

TO DOWNGRADE FROM 1.6.53 IT IS IMPORTANT TO HAVE THE DRIVE, WHICH IS LOCKED TO THE BOOTLOADER. IT HAS TO BE IN A WORKING CONDITION. You will have to use exactly that drive (I mean you have to use the serial number from the drive, which archos has locked down to its bootloader) to downgrade. Because another drive will not be acceptable. You can buy an old most cheap western digital hdd with small capacity. But be sure it has a Marvel processor. I think almost all of them have the Marvel CPU. Then just use a free 2.3 version of WD Marvel to change its serial number and do like I've just described. Before using WD Marvel you will have to turn off the hard drive in Windows device manager.
Don't forget to copy the serial number of your drive into some notepad or anywhere else. It will help you so much when the drive dies.
Remember: if you upgrade to 1.5 and later then the bootloader becomes locked down again.
I would also recommend to have a backup Western Digital HDD with a needed serial number and the 1.1.06 firmware installed on it.
This way gives you a chance to install an SSD without changing its serial number.

As I defined, Archos locks down to 14-symbol serial number. If you upgrade to 1.5 and later with SSD which has a S/N containing a number of symbols more than 14, then the device will be lost forever (until you replace the bootloader by soldering it out). It will show you a HDD recovery screen once you upgrade. So you will need to change SSD's S/N. I tried 2 different SSDs with different S/N. The second one had 12-digit S/N. Shorter S/N doesn't make the player be locked. It just rejects the drive. In this case to turn on the device you have to place the previous drive.
Placing an image of 1.6.53 doesn't work correctly, so you will have to install the firmware using a firmware file in order to make it work correctly.

Everything you will need is posted below

1.2.05 Firmware file - Important!! Read Apr 15 Update
Hidden partition image 1.1.06
WD Marvel for Windows(x32)

I defined that if the system partition has been damaged, then Archos will ask for firmware file once you choose to repair. It won't ask for the file if only user partition has been damaged. So that's why I thought that there was an onboard version of firmware. Actually HDClone doesn't always write an image. I have 2 hard drives which I use for the downgrade trick. They are both WD3200BEVE (320GB). The first one is damaged, so I have cut a part of it. Now it has 230GB. The second one is in good condition. HDClone always works fine with the damaged hard drive. But it doesn't with the second HD. I don't know why. The program says that image has been written successfully, but the system version doesn't change at all. It's always 1.2.05 (after the downgrade with firmware file). I even tried to format the whole hard drive. Didn't work.
One day I formatted the hidden system partition into NTFS. Archos recovered the system partition, but... it still had NTFS. And no unallocated space!! Whatever I tried to do with that NTFS partition (even filled it with some files, about 100MB) the system stayed working. That was quite strange for me. I didn't and still don't know where the system files were placed.

Several days ago I clicked on Buy now button on eBay. I was almost at checkout. But while typing a message to the seller I asked myself which product number to point (I have 2 hard drives with different serial and product numbers and using them with the same player). I was confused. And then I had an idea of running same plugin files for the same hard drive, but with another Archos player.
Here's the trick. Plugins are not dependent on a serial number of the player. They are dependent on a product number shown in system settings. That's why people fail to run downloaded (from the Web or elsewhere, i.e. not native) plugin files under the booted system. Because the plugins need a native product number to be run. Below you will find the 1.6.53 system image and 2 plugin files for the image.
I used a hard disk with 1.6.53 system from 504 with unlocked plugins. Place the hard drive into another Archos. Archos must be unlocked from the lock down(i.e. must have firmware older then 1.5.x. Downgrade is described in the beginning). Wait until the system boots. Copy the plugin files into HDD. Run the plugin files. Done. I have 2 players, so I returned the hard drive to the donor player. Now it's time to run the 1.6.53 firmware file, beacuse my Archos started to show error massages while I was trying to play any video file, even the ones which are not related to plugins. Then I tried to play a music file. After that Archos reboots, PLUS Archos didn't want to connect to PC. So I had to use the firmware file to solve it.
Archos generates its product number according to HDD's serial number.

Hidden partition image 1.6.53
Videopodcast plugin
Cinema plugin
Firmware 1.6.53

I defined that Product number depends on HDD's serial number. So if you want the plugins to be run you will have to change the serial number of your Western Digital hard drive to SB0403SJGENBUD. Next you will get the needed product number for plugins. It is C8U5LBXNW29KJG.

I changed the link to the clonning program because I received a notification from 4shared admin that I posted a copyrighted material. How to unpack the program: main archive file (password: ☤ﮝﻻ⋩ﻛԷ따덕ڦ㏶쳥) contains another archive file called (password: ☃✧〠Ⓙ〶✰ǬⓆ). Unpack the file Reports.rar from and change its extension to exe. Then run it to install the program. If those passwords don't work just let me know.

Gen4 plugins cannot be used for gen5 devices. Plugin files are different in size and there's also a different product number generation algorithm. For instance, if I place the same HD into gen4 and then into gen5, the product number would be different.[color=#0000FF

Aug 5 2016 UPDATE
I defined that Archos locks down to its HD starting from 1.4.06. So 1.4.03 is safe for replacing HD. But be careful about its serial number length. When I tried to update from 1.1.06 to 1.6.53 with 32GB SSD having a 16-symbol SN, Archos bricked. Just getting a usual HDD-error after starting it. Then I used another 504 device and tried to install a 256GB SSD with 12-symbol SN. The same error. But the player has not been bricked! Because when I placed its native HD, the it started fine! I think this is because I bought Archos already been locked down with 1.5 firmware. Then I just downgraded to 1.2.05. And then tried to lock down to SSD with SN, which contained 12 symbols (i.e. less then 14, which I think is required for successful upgrade). I don't know why (and from where?) Archos 'remembered' previous SN, but now I have Archos working with 256GB SSD, firmware 1.6.53 and bootloader 1.4.03.
I don't know where the info about plugins is being stored, but I understand that bootloader has to be erased before writing it again (i.e. before upgrading). So I guess that info about plugins (and HDD serial number) must be stored somewhere in Davinchi proccessor memory. I don't know what happens if one upgrades with SN containing more than 14 symbols, but I tried to replace the reason-of-brick SSD with other different hard drives, but Archos didn't accept them too. Maybe SN is being stored in a variable, which cannot contain more than 14 symbols and thus longer SN causes an error. But it seems that shorter SN doesn't cause any errors which could break the device.
After recovering with native HD having 1.5 installed on it, I downgraded bootloader to 1.4.07. Thus I defined that the lock down function didn't disappear. Then I used an image of 1.6.53 with 1.4.07 bootloader. I wondered that I could play files with no bugs! No reboots or errors! So I defined that using 1.2.05 bootloader I cannot use newest firmwares normally. I guess it has a bit another booting algorithm. OK. Next step was to find out the 'profit' bootloader where there would be an ability to use 1.6.53 image and no lock down to HD. Got it! It was 1.4.03. Just install it (downgrade from 1.4.07 is possible) and install 1.6.53 image file onto HDD or SSD.
Now I have a possibility to watch DVD files (which need to turn on HD every 10th second) from SSD with much lower power consumption than using a HDD.
If you need 1.4.03 firmware, here's the link

As I defined later, my 256GB Kingspec SSD is buggy because of long power-on delay. I placed Kingspec SSD (32GB) instead and it worked like a hard drive, i.e. it turned on quickly.

Some people had 3 files in System/POS directory. My Archos contains them too. Those files are password-protected SFX zip-archives containing Archos firmware. They contain a firmware files (1 file in every archive). The files are different in size. I guess it's 1.1.06 firmware (according to the archive names). I seemed to crack DemoRecovery_1_1_06.exe. But I think the password was incorrect. I get an error about different CRCs. I will post other passwords once I crack them.
DemoRecovery_1_1_06.exe 6-symbol password:9,&t5\
If you extract the file successfully, please share it with me.


I bought a CF to IDE 2.5 adapter and tried to connect 2 CF cards to 504. The converter has a jumper to set master/slave modes for CF cards. I installed OS on 2 drive, spent some time to define how 504 works with 2 cards. So, the player sees only one card been previously set to master mode. Another one has not been recognized. So Archos 504 can work only with 1 device which you connect to its IDE interface.
2 CF cards connected with different OS versions installed:
1) No jumper (Cable Select mode): A504 boots up with Archos logo frozen.
2) Set the jumper to Master/Slave: the 1st card boots up. The second one is "invisible" for A504.
3) Slave/Master: the 2nd card boots up. The first one is "invisible" for A504.
1 card installed:
1) No jumper: A504 boots up with "System damaged" menu. Clicking "repair" or other options will reboot the device.
2) Set the jumper according to card's position: system boots fine.
3) Set the jumper not according card's position (jumper: Master/Slave with the card installed into Slave connector or vice versa): same as 1: A504 boots up with "System damaged" menu. Clicking "repair" or other options will reboot the device.

So. I have one more thing to try. The thing is those cards were in "fixed" mode, which means they work are recognized as hard drives. Modern CF cards are mostly "non-fixed", so they work and are recognized as a removable device. So I want to connect a non-fixed CF card and then try to mix fixed and non-fixed cards. Maybe non-fixed will be recognized as a removable device. So you could use a lot (about 1TB) of portable memory in Archos 504! That would be awesome.
I also tried to connect a SATA hard drive using SATA to IDE 2.5 converter. I formatted a SATA HDD and installed the operating system using HD Clone. Connected it to the player and then powered it on. I got a message FAT is corrupted. Tried to reinstall the OS with Archos itself. Formatted, connected to PC, transferred the firmware file. Disconnected and got another error: "Media failed". Rebooted and... "Media FS failed". So no success with SATA devices, I guess. I had only one SATA HDD to try. Maybe another HDD would not fail.
I also tried to use SD to IDE 2.5 and SD to CF converters. Didn't work.
It's strange but my 504 doesn't work with my SSD being set to "Cable Select" mode. BUT if I set "Slave" it works fine. BUT if I connect a WD hard drive being set to Cable Select, it works. But the player doesn't work with it being set as a slave. I'm confused.
I successfully installed 1.8" hard drive using CF to IDE 2.5 converter. Worked fine.

I bought 704 wifi with latest firmware 1.7.53. I removed its hard drive and placed it into 504. OS didn't start.
I also bought 2 RAM chips for 504 which will give 256MB of RAM instead of 64MB. Will post results later.

Corrected wrong info about 14-digit S/N and the SSD experiment.

I tried mSATA to IDE converter with mSATA SSD. My conclusion is Archos doesn't work correctly with any converter that has a controller. So it's not possible to make it work with SATA drives and SD cards. Only CF or IDE drives are accepted.

I changed the info about the lockdown version of firmware. It's 1.4.06. So the latest firmware with no HD lockdown is 1.4.03.
I forgot to post a step-by-step instruction on restoring a partition image from file onto the disk. So here it is.
Run "HD Clone"->Restore partition->chose the folder where 1.1.06 or 1.6.53 image is: first click on the needed drive from the left panel. Then using the right panel go to the folder with the needed image folder and click on it-> click Next (if the button is not active, it means you didn't choose the image)->in the next window "Target partition" click "Show all partitions" to uncover the hidden partition->find the hard drive of your Archos and click on the smaller partition called "unnamed". It's size has to be around 97MB->click Next->Start->Start copying->(Waiting)->Automatically->Quite HDClone. You're DONE!
704TV has been excluded from the free-plugins list. It has a HD lockdown on all firmwares

I defined that my image of the hidden partition will not help to boot from another Gen4 device other than 504. Once you try to do that Archos refuses to boot the OS and then the "Partition is damaged" message appears.
Here's some info on a704.
I found out something interesting about the Davinci CPU TMS320DM644. It has a UART0 interface which it uses for the boot if BSEL0 and BSEL1 pins are configured correspondingly. I soldered away the CPU, RAM, and bootloader form the main board and defined that UART0 is totally free. It is not connected to anything on the board. UART2 is also free. My idea is to read out the bootloader using UART0, edit it and than write it back. I already have a serial cable. So I just need to convert the 3.3v signal to 1.8v to be compatible with the CPU by the voltage level. I will have to get something like SN74AVC1T45 which was used for DM644 EVM. I already downloaded Davinci Flash and Boot set of software to work with Davinci. But there's another idea for using USB-Serial adaptor. According to this thread ... 89#p103926, I will have to get some special converter, which has the built-in drivers to send serial commands through the USB interface of the DVR station.
Also I got some info about the serial port on the DVR Station. It has nothing to do with any of serial ports on DM644. Some guy told me it was used to program some French Set-Top Box. I have no idea which one. But possibly, that guy could be wrong as there's some info in 704's manual about it. The control of the Set-Top Box works through the IR port of the DVR station.
I decided to send commands to Archos using the IR port on the DVR. I have no clue how to do that though, but will try to define that. I only know it uses a 455kHz frequency.
One more question I have is how to take screenshots. Someday my 504 did make several screenshots and saved them as bmp. But what button combination should be used? Here are some of them

As I defined, plugin files will work only for same devices. 504 plugins will work for 504 devices. 404 plugins will work for 404 devices. It's because of the product key generation algorithm.
For more details see my 404 topic