Fluorescent lamp broken in AV120

Old generations (2002, 2003, 2004)
Post Reply
ballaballa1556
Archos Novice
Archos Novice
Posts: 1
Joined: Mon Sep 14, 2009 3:36 pm

Fluorescent lamp broken in AV120

Post by ballaballa1556 »

Hello everybody,

I own an Archos Jukebox 120 in which I put a 80 GB hard drive quite
a while back. A short in the power supply plug caused some diodes on
the PCB to burn and a little part of the housing started to melt. After
I got the replacement diodes from Farnell, fixing the charging circuit
was no problem.

BUT: When I tested the jukebox after "fixing" it, I realized that the light
"bulb" was broken in half. Since there are no markings on the part and
my voltmeter says that the pins of the lamp get supplied with more than
it can measure (1000 V AC & 200 V DC) I have no clue where to get
a replacement. The glass cylinder used to be about 4 cm long and only
2 or 3 mm in diameter. Does anyone know what kind of lamp this is
exactly? Because of it's power supply and the way it looks I suspect
it to be a real fluorescent lamp, but that's just a guess. Where would
I find such a lamp? Since I'm from Germany, any Internet source with
international shipping would be perfect...

Thanks a lot in advance!

Andreas
rowden9
Archos Novice
Archos Novice
Posts: 2
Joined: Sun Sep 22, 2013 7:29 pm

Re: Fluorescent lamp broken in AV120

Post by rowden9 »

Hi, I am sorry I can't help you with the light bulb request from 2009. But I hope you can clue me into the values or part numbers of the diodes you used for your charging circuit repair.
thanks,
Martin
Post Reply

Return to “AV400, AV300, AV100 and JBMM”