Forum.ArchosFans.com
Archos 80 G9 1.5Ghz 1GB RAM ICS 8GB: Buy now (free shipping)
Archos 80 G9 1.5Ghz 1GB RAM ICS 250GB: Buy now (free shipping)
Archos 101 G9 1.5Ghz 1GB RAM ICS 8GB: Buy now (free shipping)
Archos 101 G9 1.5Ghz 1GB RAM ICS 250GB: Buy now (free shipping)
 * Register    * Login 

It is currently Wed Apr 23, 2014 1:43 pm

All times are UTC + 1 hour



Post new topic  Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Fri Apr 13, 2012 6:50 pm 
Offline
Archos Novice
Archos Novice

Joined: Fri Apr 13, 2012 6:25 pm
Posts: 3
Hi,

I wanted to get the opinion of other Archos users on how I should deal with Archos over the issues I've had since I received my 80 G9.

I live in Florida and my fiancee is in New York due to his job. He bought me the Archos as a gift over a month ago. Yet I have had very little use and enjoyment out of my new tablet. He set everything up and shipped it to me. He said it was great and he wanted to get himself one.

I received the Archos and the internet immediately began to give me problems. The entire first week was spent trying to get the internet to stay on. I was not able to do much with it. The next week I finally decided to call Archos customer service to get help. After many days and ideas from the Archos techs that didn't work, they decided to setup an RMA. I still had to call back a few times because they had my name and address wrong on the RMA. Every time I double checked and asked them what am I sending back to Archos AND if I was going to get back a new Archos, to replace my new Archos. By the time the RMA was correct, I unplugged it and the entire metal piece came out of the USB slot. Even though I barely used it, my brand new Archos was now broken. I called back customer service and they still said to just send it back, they will send a new one that would have the internet and would not be broken.

I did as I was told. I put everything back in the box, bought a post office box with insurance and tracking info. Over a week later they finally shipped it off to me and I received it in another week. In nearly a month I had yet to enjoy my tablet gift. :roll:

I received the shipment last week and opened it to find...an Archos unit only. I called back and they said that I was only supposed to send the unit. No accessories. The techs told me multiple times to send everything back. I also wanted to know even if i didn't send back the cord, why would I consider the box and manual an accessory? They promised to send me a new charge cord. However, I was also displeased to see that I sent back a brand new Archos, in both use AND looks, only to receive an Archos unit that was blurry and scratched like it had been kicked around for a few months. I asked over and over and was told I would receive a brand new unit. This customer service rep said I should not have been told that because they do not have new units only refurbished ones. She said I could do another RMA to get one that "looked better". I really did not want to spend another few weeks paying shipping to send an Archos unit back and forth until I received one that was both working and looked clean. I decided to just keep what I have. I was displeased but at least it should work.

I waited for the charge cord and could not use the Archos until I received it. I got it yesterday and charged the tablet. It was done last night. My family and I gathered in the den to watch our shows and I was excited to start setting up my "refurbished" Archos. My nieces 4 and 7 sat next to me to get a look at the tablet.

As I scrolled through the apps to go to "Settings" I accidently clicked a video program. Before I could hit the back button to continue setting up the tablet, my family and I were shocked to see (and hear) hardcore lesbian porn playing on my "clean, refurbished" tablet. My nieces had questions no one wanted to answer and once again I'm disappointed with everything Archos.

I called Archos today about the issue and ALL the issues I've had since owning and barely using the tablet and was just told that they would set up an RMA for me to send it back and get another refurbished one. I am VERY, VERY displeased with Archos and their customer service. The CS rep sounded like he could care less about my issues with the company and product and I really want to call back and see if I could speak to a manager. At most, I would just like to receive a new working Archos.

What should I do?


Top
   
 
PostPosted: Fri Apr 13, 2012 8:37 pm 
Offline
Moderator
Moderator

Joined: Fri Jan 09, 2009 2:02 am
Posts: 1765
Location: Honolulu
You can do settings/repair/resetmedia to clear those files. It may clobber some example files but those uninteresting files probably retrievable elsewhere. The written Rma instructions are very explicit to not send in accessories. I went thru my first rma and was surprised by that in the email and confirmed it in writing elsewhere... maybe their webpage.

I question whether your original device had any problem. Now I think a firmware bug is making at least the dolphin browser throw up messages about lost signal which can be ignored. It is either false or is so brief that it has no impact. Maybe I am wrong but expect a fix for this and other things thru firmware updates.

In general for any company I would use their live help as little as possible and expect it to be the least trustworthy compared to their written web or email info (I mean official automated email such as I got with rma process that I initiated on the web). I never use phone contact. These people are likely overwhelmed and out of info loops and not well funded because it would be a huge burden added to the original purchase price. Archos can have rough firmware early in product life, and I expect they are drowned in returns of perfectly good devices. Usually they rapidly rerelease the firmware fixes.

_________________
a101g9 a70g8 an10g2 sg42 sg5 voy115


Top
   
 
PostPosted: Fri Apr 13, 2012 9:59 pm 
Offline
Archos Novice
Archos Novice

Joined: Mon Apr 09, 2012 12:34 am
Posts: 18
Seems like you've had a bad experience.

I purchased a 70IT 259gb last year which I really liked. Unfortunately it developed a problem in that one corner of the screen was darker that the rest which made ebook reading a bit of a problem. I reported this to Archos by email and they told me to return it (they also told me not to send anything else) which I did. Here in the UK they also advised that they did not do a repair, just a replace. Luckily my Warranty had not expired. Heard nothing for a few days and then received an email from them to the effect that while they wanted to replace they could not because they didn't have the same model in stock and would I accept an upgrade? Too right I would! I am now owner of an 80 9g 250gb Turbo and it's brilliant.

I appreciate that this is by far better service than you have received but I can't praise them enough for the service they provided me.


Top
   
 
PostPosted: Sat Apr 14, 2012 10:08 pm 
Offline
Archos Novice
Archos Novice

Joined: Fri Apr 13, 2012 6:25 pm
Posts: 3
viking wrote:

I question whether your original device had any problem. Now I think a firmware bug is making at least the dolphin browser throw up messages about lost signal which can be ignored. It is either false or is so brief that it has no impact. Maybe I am wrong but expect a fix for this and other things thru firmware updates.


It wasn't just that the internet bar was low or disappeared. Nothing would go online. There was a firmware update that may have worked. Unfortunately, the metal piece came out of the unit that I had barely used and I had to return it because it would no longer charge anyway. If it had not fallen apart on me, the last firmware update may have fixed the internet problem with the wireless router and I could be in my happy place now.


Top
   
 
PostPosted: Sat Apr 14, 2012 10:10 pm 
Offline
Archos Novice
Archos Novice

Joined: Fri Apr 13, 2012 6:25 pm
Posts: 3
mightyjimbo wrote:
Seems like you've had a bad experience.

I purchased a 70IT 259gb last year which I really liked. Unfortunately it developed a problem in that one corner of the screen was darker that the rest which made ebook reading a bit of a problem. I reported this to Archos by email and they told me to return it (they also told me not to send anything else) which I did. Here in the UK they also advised that they did not do a repair, just a replace. Luckily my Warranty had not expired. Heard nothing for a few days and then received an email from them to the effect that while they wanted to replace they could not because they didn't have the same model in stock and would I accept an upgrade? Too right I would! I am now owner of an 80 9g 250gb Turbo and it's brilliant.

I appreciate that this is by far better service than you have received but I can't praise them enough for the service they provided me.


I'm glad you had better results than I did mightyjimbo. I had searched online about the internet problems and saw many people who talked about the great customer service they received, so I really expected things to be handled better. I'm very disappointed.


Top
   
 
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 5 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Hosted by Forumatic™