Cannot charge 80 G9
Page 1 of 1

Author:  phantomlord [ Fri Feb 24, 2012 3:59 pm ]
Post subject:  Cannot charge 80 G9

The first problem I noticed was with the provided charger. The connection between the USB cable and the AC charger brick was bad and required quite a lot of fiddling for it to work.
Then the device itself stopped charging, showed plugged in on the screen, but the actual meter did not go up.
Now it won't turn on at all.

The other thing... this device has no serial number sticker! The funny thing is that the registration page doesnt show where to find the serial number of this model. So I cannot contact support either.

Author:  jiyong [ Fri Feb 24, 2012 4:42 pm ]
Post subject:  Re: Cannot charge 80 G9

Have you checked with a different USB charger or even from a PC?

Author:  phantomlord [ Fri Feb 24, 2012 5:25 pm ]
Post subject:  UPDATE: Cannot charge 80 G9

I did the trick to keep the power button pressed for 15 seconds and that changed something, the next time I connected it to the charger, the power light will blink every 2 seconds. 20 minutes afterwards the device powered up and seemed to be charging, but....
It still does not seem to be charging properly, after about an hour, the indicator it still at 0%, even unplugging for a couple of seconds triggers a shutdown.
I've also found the serial number sticker, its behind the stand up lever, however, the serial number does not show in the OS screen.

Author:  iang9 [ Fri Feb 24, 2012 5:41 pm ]
Post subject:  Re: Cannot charge 80 G9

the s/n is also on the box - very hard to read inside the leg supprt.

this sounds like my 1st g9 which lasted a week. I'd suggest leaving it on and charging overnight and if its still not right try a factory reset. If that doesn't help return for a new one (or a refund)

Author:  over's tab [ Fri Feb 24, 2012 10:06 pm ]
Post subject:  Re: Cannot charge 80 G9

Archos puts in a App under (A registration) loaded already, it gives details on where and what to do also a user manual app, they really should show up on home screen and be more clear but they are there when you touch top right app button. I for one like a subtle hidden #

*make sure your using original Archos usb cable but it could be like OP wrote, the wall plug that the usb goes into may be defective. see if you have another on from BB phone etc. that has same world specs (I have one from BlackBerry that with Archos cable works like original) edit: the BB adapter does not work with factory usb cable. also, I think it has been confirmed by others that it is the Archos usb cable that is special, along with the "special" design of charging the g9 flash :oops:

Author:  pucky [ Mon Feb 27, 2012 10:44 am ]
Post subject:  Re: Cannot charge 80 G9

My children all three bought one and two of them now 2 of them will no longer charge, clearly the mini usb connection is faulty.
I tried registering the devices but constantly get a ' wrong serial number' popup so can not even connect customer service.
A little dissappointed...

Author:  Ian Robinson [ Mon Feb 27, 2012 4:55 pm ]
Post subject:  Re: Cannot charge 80 G9

I bought my g80 last October and its about to go back to Archos as it will only charge at slow rate even on dedicated charger. Not bad since we have just returned my wife's G9 101 for precisely the same reason. There must be a weakness with the mini usb connector.

Author:  Misterdeman [ Mon Feb 27, 2012 9:04 pm ]
Post subject:  Re: Cannot charge 80 G9

I had mine returned, got a new one, also a different charger, seems to work now.

Author:  phantomlord [ Thu Mar 01, 2012 1:49 pm ]
Post subject:  Re: Cannot charge 80 G9

Well, I am happy to report that the Archos is now alive and kicking.
I left it charging almost 18 hours under close monitoring and now it is doing a normal charge and dis-charge cycle.
I was also able to register it in the archos website.
The only thing that did not work out well is the email I sent archos for help, nobody has replied back... I guess none of the 250 employees is monitoring that email address.
Lessons learned:
1. As soon as you power up your new archos, do the in-device registering to be ellegible for support.
2. Try never to dis-charge it under 20%
3. Archos email support is a joke.

Author:  ces001 [ Tue Nov 19, 2013 12:36 pm ]
Post subject:  Re: Cannot charge 80 G9

I have an Archos 80 G9 turbo with 250 gb hard drive. I have had it now for about 2 years and recently, it would not charge when plugged in. After three days I was about to throw in the towel and buy a new tablet, when I got the idea to try a direct wall outlet instead of the power strip I was using. I plugged it directly into the wall outlet and (voila!!!), the charging indicator showed that it was finally taking a charge. It turned out that the power strip I had been using for well over a year would not charge my tablet even though there are other fixtures (lamp, etc.) plugged into it and getting power. Hopefully this post will help some of you who have charging problems. You problem just might be your power strip.

Page 1 of 1 All times are UTC+01:00
Powered by phpBB® Forum Software © phpBB Limited