Forum.ArchosFans.com

Unofficial Archos Support Forum
It is currently Sat Apr 04, 2020 9:46 am

All times are UTC+01:00




Post new topic  Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Skinomi Archos 101 Skin
PostPosted: Fri Dec 31, 2010 9:59 pm 
Offline
Archos Novice
Archos Novice

Joined: Sun Dec 26, 2010 3:19 am
Posts: 10
Location: Florida
So, the skin from Skinomi, that I bought for my Archos 101 came in today, I followed the directions, and put it on. It looks terrible to say the least, it has bubbles, and marks, and visible wrinkles, does anyone have any ideas on how I can fix it?

_________________
Remember, The Web Doesn't Forget


Top
   
PostPosted: Sat Jan 01, 2011 5:14 am 
Offline
Archos Novice
Archos Novice

Joined: Sat Sep 18, 2010 6:07 pm
Posts: 22
I had the same problem. I took it off and re-applied it, and then did it again. I did the wet mount a few times, and a dry mount, and it still looked bad. I even let it sit overnight, but it still looked awful the next day. Thinking I could get past the bubbles and smudges, the device started to have a mind of its own. Buttons would press when you pressing on the other side of the screen, or wouldn't press at all, etc. I took it off, it works much better. Though I'm still looking for a screen protector, for now it works.


Top
   
PostPosted: Fri Jan 07, 2011 5:34 am 
Offline
Archos Novice
Archos Novice

Joined: Fri Jan 07, 2011 5:23 am
Posts: 1
I made the mistake of ordering the Skinomi Skin Protector for $25. It's the full body protective cover. When I first applied it, I thought my Archos 101 looked like garbage. I waited 7 hours for it to dry and thought it would look better. I was wrong. My 101 now looks worse than garbage. The full body skin looks like somebody stuck scotch tape all over it. I couldn't stand it anymore . . . so . . . I just peeled the whole thing off. What a waste of $25.


Top
   
PostPosted: Wed Jan 12, 2011 5:28 pm 
Offline
Archos Novice
Archos Novice

Joined: Thu Dec 23, 2010 7:49 pm
Posts: 15
I have purchased and applied the skinomi screen protector on my 101 with no problems. I used the wet application and took my time, paying extra attention to minimize as many bubbles as possible with the provided applicator. I have had no problem. After 48 hours of drying, all bubble have evaporated and disappeared. Just take your time... One of the best screen protectors I've ever used. I have them on all my electronics.


Top
   
PostPosted: Sat Mar 05, 2011 9:30 pm 
Offline
Archos Novice
Archos Novice

Joined: Sat Mar 05, 2011 9:16 pm
Posts: 3
Hi all, I put the screen protector on from Skinomi and it went on pretty easily. At first it had odd looking hazing under the skin but after it set over night they dried and went away.
My problem is that now when I first turn the Archos on the search button on the top right keeps acting like I am presseing it. It lights up and goes to the search screen and still keeps lighting like I am pressing it over and over again.
I have even cut out the skin right over the button and this seems to help but still on occasion it goes to search for no reason. Is anyone else having this problem?


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 5 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited