Forum.ArchosFans.com

Unofficial Archos Support Forum
It is currently Tue Oct 24, 2017 4:54 am

All times are UTC+01:00




Post new topic  Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Archos 43 Dead?
PostPosted: Sun May 27, 2012 5:15 pm 
Offline
Archos Novice
Archos Novice

Joined: Tue Mar 20, 2012 4:03 am
Posts: 2
My Archos 43 was working fine yesterday - I don't do much with it routinely, I was just listening to music and playing some word search game. It was low on battery power (21%) so I decided to leave it on overnight so it would run down all the way before I charged it.

Have tried to plug it in via USB adaptor today and my PC is not recognizing that it even exists; the Archos itself is not responding (no light or anything), either. Archos' website says to leave it plugged in for 'several hours.' It's been plugged in for approx. 1.5h now with still no response.

Is my Archos dead? Shouldn't it still be registering as a removable media drive when being plugged into my PC?


Top
   
 Post subject: Re: Archos 43 Dead?
PostPosted: Sun May 27, 2012 6:48 pm 
Offline
Archos Expert
Archos Expert

Joined: Thu Feb 03, 2011 2:33 pm
Posts: 218
Johnny Sarcastic wrote:
Is my Archos dead?

1.5 hrs isn't 'several hours' so be patient

Johnny Sarcastic wrote:
Shouldn't it still be registering as a removable media drive when being plugged into my PC?

Not without power.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 2 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited