Forum.ArchosFans.com

Unofficial Archos Support Forum
It is currently Sat Nov 16, 2019 10:42 pm

All times are UTC+01:00




Post new topic  Reply to topic  [ 214 posts ]  Go to page Previous 14 5 6 7 811 Next
Author Message
PostPosted: Mon May 24, 2010 12:09 am 
Offline
Archos User
Archos User

Joined: Sun Apr 25, 2010 3:30 am
Posts: 59
Location: Chicago, IL, US
llaume wrote:
(dot dot dot)I will make a small tutorial on "How to get a working UNR 9.10 on your Archos 9 tablet ?" pretty soon (hopefully this w.e.).

Cheers

I for one am greatly looking forward to this. Especially after my insanely powerful ASUS laptop arrives, I'll be free to keep my "9" as a tweakable machine. :)

I'm hoping that, between Linux and the new SSD, this could yet be a pretty speedy, efficient little web-surfin' machine. :D


Top
   
PostPosted: Tue May 25, 2010 6:06 pm 
Offline
Archos Novice
Archos Novice

Joined: Fri May 21, 2010 5:04 pm
Posts: 3
It's been quite hard to get UNR 9.10 working ... i've had to rebuild the linux kernel in order to be sure to get the option required by egalax
regarding raw access to serio and so one (tooks 7h to recompile ...). In the end, it was working but time consuming. I finally tried upgrading
to UNR 10.04 as proposed by yvesdm3000 and provided you have a usb wifi dongle it is quite easy to get a working Archos 9. Otherwise,
you may consider yvesdm3000 proposal in this forum which is roughly similar to the following (except for wifi and Archos button configuration):

1) install UNR 10.04 from a USB key (using a usb hub, a usb mouse and usb keyboard)

2) using your usb wifi dongle, update the system (quite a numerous number of updates -- including a kernel one) ; i think you really should do
this before continuing (it may be part of the success)

3) once updated, go to "System > Hardware drivers", activate the Broadcom STA one which should be in the list (this requires an internet
connection, to get the drivers ... here is the use of the wifi dongle again)

4) use the dropbox solution to get poulsbo working:

wget http://dl.dropbox.com/u/1338581/Gma500/ ... o_lucid.sh && bash ./poulsbo_lucid.sh

5) touchscreen :

wget http://home.eeti.com.tw/web20/drivers/t ... k26.tar.gz
tar vxfz eGalaxTouch-3.01.4001-32b-k26.tar.gz
cd eGalaxTouch32
sudo ./setup.sh

>choose PS/2 by pressing "2"

sudo vim.tiny /etc/default/grub

add "mem=980mb i8042.nomux " to the option GRUB_CMDLINE_LINUX_DEFAULT "mem=980mb" is for poulsbo purpose

sudo update-grub

sudo vim.tiny /etc/rc.local

add echo -n "serio_raw" > /sys/bus/serio/devices/serio1/drvctl

i also added

echo -n "atkbd" > /sys/bus/serio/devices/serio0/drvctl

but i'm not sure it is neccessary (serio0 corresponds to the two left-upper buttons of the Archos - you will be able to ask for
the virtual keyboard using the bottom one afterwards).

after rebooting, you should open a terminal and calibrate the touchscreen by launching

"eGalaxTouch" then select Tool > Linearization > 25 points

Then you may add the virtual keyboard "onboard" (sudo apt-get install onboard) and using "System > Key Shortcuts", you can associate the
bottom button (the one with a keyboard like drawing) to the launching of onboard (or another virtual keyboard)

You should now have a working Archos 9 ... i'm still investigating the possibility to get the touchpad working again.

I've been playing around and successfully get the touchscreen working on F11 and UNR 9.10, 9.04 but i've had to rebuild
the kernel which was not worthing it. UNR 10.04 seems quite good tho.

Thx to yvesdm3000 btw :) ; ArchosLounge.net is interested in having a full tutorial, it may be great if we can share our experiences
and try to get a nice tuto.


Top
   
PostPosted: Thu May 27, 2010 11:38 am 
Offline
Archos Novice
Archos Novice

Joined: Thu May 27, 2010 11:29 am
Posts: 1
Hi, thx for the great help on this topic.

I wrote a german tut on my website (http://www.testkaninchen.de/?p=5)

@ yvesdm3000:
can you describe how to patch the florence to bring it to a panel?

And here is a question for the cracks: how can i simulate a right mouse click? Or is it possible to use the optical mouse and there buttons ?


Top
   
PostPosted: Thu May 27, 2010 4:23 pm 
Offline
Archos Novice
Archos Novice

Joined: Fri May 21, 2010 5:04 pm
Posts: 3
a 3 sec press with the stick should, by default, simulate a right click ... i'm still not able to get back the touchpad working :(
i've replaced virtual keyboard by CellWriter which can be launched at start-up adding "cellwriter&" in the end of /etc/gdm/Init/Default

...
fi
cellwriter&
exit 0

you may wish to replace /usr/share/cellwriter/profile file by a symbolic link to ~/.cellwriier/profile (by a cd /usr/share/cellwriter/; sudo rm profile; sudo ln -s ~/.cellwriier/profile) in order to train cellwriter only once for both root and user.

Regarding screen rotation, it seems to be unstable on 10.04 :(

(cf https://bugs.launchpad.net/gma500/+bug/586304)

It was working pretty well on 9.10 ... too bad :)


Top
   
PostPosted: Thu May 27, 2010 11:49 pm 
Offline
Archos Novice
Archos Novice

Joined: Thu Apr 29, 2010 8:33 am
Posts: 39
I have also moved to cellwriter now. And did some patching on it too lol. I have the panel struts working to put it at the bottom and make it push the windows up. Also added an option to 'toggle' the visibility of cellwriter to make the top-left button work using a keyboard shortcut.

Using gconf-editor:

/apps/metacity/global_keybindings/run_command_1 = <Alt>Scroll_Lock
/apps/metacity/global_keybindings/keybinding_commands/command_1 = /usr/bin/cellwriter --window-struts --dock-window=2 --show-window

(the --window-struts and --dock-window=2 won't work if cellwriter is allready running)
(I added an option --toggle-window so when the keyboard is shown and i hit the button, the keyboard will be hidden)

I'll post the patch in a couple of days. (I've sent my patches to Florence too but doesnt look like much is moving there, i think he doesn't know what 'struts' are I guess.)

-Yves


Top
   
PostPosted: Tue Jun 01, 2010 5:04 pm 
Offline
Archos Novice
Archos Novice

Joined: Thu Apr 29, 2010 8:33 am
Posts: 39
If anyone want screen rotation back for your Archos 9, here is a patch against the ubuntu 10.04 source package. Enjoy !

http://launchpadlibrarian.net/49505984/ ... .patch.txt

-Yves


Top
   
PostPosted: Tue Jun 01, 2010 7:55 pm 
Offline
Archos User
Archos User

Joined: Fri Dec 04, 2009 10:53 am
Posts: 78
Hi,

I played with mplayer patched for vaapi support and I'm quite disappointed ... When using vaapi support, the acceleration is obvous but the decoding quality is really bad (blocks and tearing).

Even an old Xvid (704*400) which runs well on Win7 (CPU only decoding) is unwatchable with my fedora.


Lots of guys on the web says that HD is flawless with their GMA500 netbooks, but they're running more powerfull CPU ...

What about you ?

Thanks


Top
   
PostPosted: Tue Jun 01, 2010 8:24 pm 
Offline
Archos Novice
Archos Novice

Joined: Thu Apr 29, 2010 8:33 am
Posts: 39
I havent touched va yet since it needs the texturing thing that is incompatible with the ShadowFB option we currently need to keep it running stable. That is one of the next things on the agenda...

By the way there should be GStreamer modules available now that enables any gstreamer app use VA (like totem or most other graphical players out there)

Oh and btw, isnt VA supposed to decode h264 and the likes? Forcing an unsupported codec to VA probably decodes and encodes again, that is a bad idea on such a slow CPU as ours...

Yves


Top
   
PostPosted: Thu Jun 03, 2010 10:02 am 
Offline
Archos Novice
Archos Novice

Joined: Thu Apr 29, 2010 8:33 am
Posts: 39
This might be of use for some people who like reading pdfs using evince. It adds a button to the toolbar that makes the pointer drag the document instead of making selections.

http://mail.gnome.org/archives/evince-l ... 00023.html

patch against ubuntu 10.04 version of evince

Yves De Muyter


Top
   
PostPosted: Fri Jun 04, 2010 1:15 pm 
Offline
Archos Novice
Archos Novice

Joined: Fri Jun 04, 2010 10:00 am
Posts: 3
Hello,

I've just installed jolicloud on my Archos 9, works quite well out of the box (poulsbo and wifi ok). My main problem is now the touchscreen... I've tried many combinations to have it work but it seems useless...
I've installed the latest version of eGalaxTouch
I have in my rc.local :
Code:
echo -n "serio_raw" > /sys/bus/serio/devices/serio0/drvctl
echo -n "atkbd" > /sys/bus/serio/devices/serio0/drvctl


It seems that I have the touchscreen, but with no calibration and when I launch the calibration tool (via eGalaxTouch or TKCal), either it tells me that no driver is found (depending on the previous parameters) or it hangs in eGalaxTouch (going into Tools, Calibration) or I can't calibrate (nothing respond using TKCal).

Using eGalaxTouch, I have this error :
Code:
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 61 (X_ClearArea)
  Resource id:  0x3800006


I am quite in trouble with that, and would love to make my Win7 go away... but still can't... any idea why this appends

Don


Top
   
PostPosted: Fri Jun 04, 2010 1:22 pm 
Offline
Archos User
Archos User

Joined: Fri Dec 04, 2009 10:53 am
Posts: 78
Hi,

You are echo'ing in the same device :
/sys/bus/serio/devices/serio0/drvctl

serio_raw is "serio1"

Bye


Top
   
PostPosted: Fri Jun 04, 2010 4:35 pm 
Offline
Archos Novice
Archos Novice

Joined: Fri Jun 04, 2010 10:00 am
Posts: 3
Yes, thanks that wasn't clever from me ^^

So, now, if I have :
Code:
$ sudo cat /etc/rc.local 
#!/bin/sh -e
echo -n "serio_raw" > /sys/bus/serio/devices/serio1/drvctl
exit 0


I've reinstalled eGalaxTouch driver, reloaded gdm and that's great. Next thing, a keyboard as a panel at the bottom shown and hidden using the keyboard button on the left ! (begining to love my A9 with jolicloud)

don


Top
   
PostPosted: Fri Jun 04, 2010 6:04 pm 
Offline
Archos Novice
Archos Novice

Joined: Thu Apr 29, 2010 8:33 am
Posts: 39
Cellwriter is a good keyboard. You can make a global shortcut key to it to run it this way:

/usr/bin/cellwriter --show-window --window-struts --dock-window=2

I'll post a patch shortly that fixes an issues with --window-struts and also adds a command --toggle-window (shows window when hidden, hides window when shown)

-Yves


Top
   
PostPosted: Fri Jun 04, 2010 9:48 pm 
Offline
Archos Novice
Archos Novice

Joined: Fri Jun 04, 2010 10:00 am
Posts: 3
Thanks, I'll try to find a way to set the keybinding for cellwriter. But the gnome-keybinding-properties utility segfaults on jolicloud.
Another problem is that the xorg config is resetted on every reboot. I think I've already read something on that in the latest X server, i'll google a bit for it and try to post something on how to have a good setup for Jolicloud on A9.

Don


Top
   
PostPosted: Mon Jun 07, 2010 10:48 am 
Offline
Archos User
Archos User

Joined: Fri Dec 04, 2009 10:53 am
Posts: 78
Hi,

I finally got an ubuntu 9.10 working on my Archos9 ! Seems easy for most people, but ...

My problems were :
- Last 2.6.31-22 kernel update which breaks poulsbo support (I did a full update, so ...), don't forget to stick at 2.6.31-21 version
- Then I had to recompile the kernel following this tip : http://linux-tipps.blogspot.com/2009/12/x-video-finally-works-linux-on-msi-wind.html
It was the exact same problem with my Fedora ... why me ?
- Finally, RTFM ... I forgot to run 'grub-update' after adding the i8042.nomux parameter to make the touchscreen work

Next, I will follow this tip to have working VA : http://linux-tipps.blogspot.com/2009/12/vaapi-accelerated-hd-video-on-msi-wind.html

Note that I had poor CPU decoding performances (Xvid 704*396, mp3) due to compiz effects activation.


Seems that my GMA500 does not like poulsbo drivers, I have to patch them. Both Jolicloud and Mandriva 2010 crashes on USB boot whereas they are supposed to support GMA500 out of the box. It's the same behavior.

So, why me ?

Bye


Top
   
PostPosted: Mon Jun 07, 2010 10:08 pm 
Offline
Archos Novice
Archos Novice

Joined: Thu Apr 29, 2010 8:33 am
Posts: 39
I submitted a patch to the XOrg developers: there is a bug in Xorg that prohibited our driver to work on version 1.7.6. With the patch I have now working OpenGL on Lucid Lynx. Now I can finally start testing VA support for Poulsbo.

For Lucid people who know how to recompile a package, the patch is over here:

https://bugs.freedesktop.org/attachment.cgi?id=36116

-Yves


Top
   
PostPosted: Tue Jun 08, 2010 12:03 pm 
Offline
Archos User
Archos User

Joined: Fri Dec 04, 2009 10:53 am
Posts: 78
Quite impressive ...

I got VA working on my ubuntu 9.10. I will try SMPlayer now with my patched mplayer.

As I was focused on poulsbo and VA, I didn't noticed that I had no sound any more. I used this tip to get it work again :
http://georgeblog.nyarangi.com/2009/10/no-sound-on-dell-mini-10-running-ubuntu.html
(I added the parameter to the already existing line)

Yves > Could you post the script wich make the screen AND the bars rotate ? I want to use easystroke to record a "round" movement and make the screen rotate ... this would be damn coooool :)

Thanx

Edit : The correct parameter is 'mobile' instead of 'basic', otherwise speaker won't mute when pluging headphones


Last edited by [email protected] on Wed Jun 09, 2010 9:49 pm, edited 1 time in total.

Top
   
PostPosted: Tue Jun 08, 2010 9:14 pm 
Offline
Archos Novice
Archos Novice

Joined: Thu Apr 29, 2010 8:33 am
Posts: 39
Hi,

I played with mplayer patched for vaapi support and I'm quite disappointed ... When using vaapi support, the acceleration is obvous but the decoding quality is really bad (blocks and tearing).

Even an old Xvid (704*400) which runs well on Win7 (CPU only decoding) is unwatchable with my fedora.


Lots of guys on the web says that HD is flawless with their GMA500 netbooks, but they're running more powerfull CPU ...

What about you ?

Thanks


Since I have now full opengl working, i can test vaapi now. It works pretty ok, no blocking or artifacts, only a jump once in a while, but that is probably because I have added so many debug messages to the poulsbo drivers...

I installed patched mplayer using this script:

http://kanotix.com/files/fix/mplayer-vaapi-latest.txt

-Vves


Top
   
PostPosted: Thu Jun 24, 2010 5:36 am 
Offline
Archos User
Archos User

Joined: Sun Apr 25, 2010 3:30 am
Posts: 59
Location: Chicago, IL, US
I was considering having another go with Mandriva 2010.1, but that's delayed. And apparently Manders (the company) is undergoing a buyout which (in my experience) tends to affect support...

I dunno. I hear that Ubuntu Lucid is bulkier than Win7, so I really don't feel like Linux is ready for prime time yet. Which is really disappointing. This is like the fifth different computer I've tried Linux on, and never one positive outcome yet. :(

And yes, I've tried different distros (SuSE, Slackware, Red Hat, Manders, Ubuntu), different front-ends (KDE, Gnome, LXDE, Xfce, OpenBox, WM), and I've tweak tweak tweaked until I was sore.

And no, I didn't rush to any conclusions. My test periods averaged six months or more. I mean I seriously TRIED. :(


Top
   
PostPosted: Sun Jun 27, 2010 7:49 am 
Offline
Archos Novice
Archos Novice

Joined: Sun Jun 27, 2010 7:46 am
Posts: 9
Can someone point me in the right direction here? I've got Ubuntu Netbook Lucid 10.04 installed. I got the wireless drivers working (it's really easy - they're on the USB install stick you make! No need to go download them...)

The problem is getting Poulsbo working properly. I get one of two results - either an endless restart of Xorg, or it runs very, very slowly - and displays a big white box on the screen. Pressing CTRL-ALT-F1 takes a good 2 minutes before it switches to the console.

I've tried both the "stable" ppa and the "fix" ppa to no avail.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 214 posts ]  Go to page Previous 14 5 6 7 811 Next

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited