Forum.ArchosFans.com

Unofficial Archos Support Forum
It is currently Sun Mar 29, 2020 5:07 pm

All times are UTC+01:00




Post new topic  Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Wed Jul 04, 2012 10:42 pm 
Offline
Archos Novice
Archos Novice

Joined: Wed Jul 04, 2012 8:25 pm
Posts: 2
Hi All

I've been trying to downgrade my Archos 7 IMT firmware using the guides on here and at http://archos.g3nius.org/. However when I try to mount the hidden partition I get an error. Can anyone spot what I'm doing wrong or at least explain what the error message is getting at?

I've included what I've done and the error below.

Thanks in advance.

[email protected]:~$ sudo fdisk -l

Disk /dev/sda: 60.0 GB, 60011642880 bytes
255 heads, 63 sectors/track, 7296 cylinders, total 117210240 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0006bb7f

Device Boot Start End Blocks Id System
/dev/sda1 * 63 59269231 29634584+ 7 HPFS/NTFS/exFAT
/dev/sda2 59271166 117209087 28968961 5 Extended
/dev/sda5 59271168 113035263 26882048 83 Linux
/dev/sda6 113037312 117209087 2085888 82 Linux swap / Solaris

Disk /dev/sdb: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xc0b8dbb8

Device Boot Start End Blocks Id System
/dev/sdb1 63 624366224 312183081 c W95 FAT32 (LBA)

[email protected]:~$ sudo mkdir /media/disk

[email protected]:~$ sudo mount -t ext3 -o offset=319675506688 /dev/sdb /media/disk

mount: wrong fs type, bad option, bad superblock on /dev/loop0,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

[email protected]:~$ dmesg | tail

[23876.891738] Buffer I/O error on device loop0, logical block 312571137
[23876.891743] Buffer I/O error on device loop0, logical block 312571138
[23876.891747] Buffer I/O error on device loop0, logical block 312571139
[23876.891752] EXT3-fs (loop0): error: can't find ext3 filesystem on dev loop0.
[23876.891810] Buffer I/O error on device loop0, logical block 312571136
[23876.891815] Buffer I/O error on device loop0, logical block 312571137
[23876.891819] Buffer I/O error on device loop0, logical block 312571138
[23876.891823] Buffer I/O error on device loop0, logical block 312571139
[23876.891888] Buffer I/O error on device loop0, logical block 312571216
[23876.891893] Buffer I/O error on device loop0, logical block 312571217

[email protected]:~$


Top
   
PostPosted: Fri Jul 06, 2012 10:56 pm 
Offline
Archos Novice
Archos Novice

Joined: Wed Jul 04, 2012 8:25 pm
Posts: 2
I have worked out what was wrong.

I needed to run...

sudo fdisk -u=cylinders -l

...to get the count in cylinders as the default for me was in sectors.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 2 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited