Forum.ArchosFans.com
http://forum.archosfans.com/

Update failed NOK (Code 207)
http://forum.archosfans.com/viewtopic.php?f=35&t=56037
Page 1 of 1

Author:  r4d0n [ Wed Aug 24, 2011 8:55 pm ]
Post subject:  Update failed NOK (Code 207)

Hi!

I own the Archos gen5 32gb IMT. A few months ago I flashed the SDE with Dualboot Angstr├Âm Linux. Everything worked fine except I had freezes when playing Music etc. Wasn't really a problem because I already had another MP3 Player.

Today I was motivated to repair the Archos so I flashed the patched 1.7.22 Firmware with Guy Fawkes Hack from here. (http://archos.g3nius.org/index.php/Arch ... re_Updates) Everything worked fine but the freezes didnt go away. So I thought maybe its a filesystem fault. Rebooted into recovery and made a format. So far so good. Now I dont have a system on it only recovery.

The problem is that every time I want to flash a new firmware (using Repair) it says "Update failed: NOK (Code 207)" Tried nearly all firmwares from the site above, as well as the Original from Archos. Even the SDE firmware didnt work.

If anyone has a hint what the cause of the Problem is please tell me!

Thanks!

Author:  mediate [ Thu Aug 25, 2011 11:32 pm ]
Post subject:  Re: Update failed NOK (Code 207)

I would try the Guy Fawkes 1.7.22 one again, after another reformat. You have a very ... peculiar problem. Never saw this before.

Author:  chucklezt [ Sun Sep 25, 2011 5:45 am ]
Post subject:  Re: Update failed NOK (Code 207)

I have the same problem. I just posted a new thread (hopefully not violating rules) but my situation is slightly different. I already had 1.7.22 installed with patch and GF, but since trying to swap hard drive Im stuck with this error even after putting the working 250GB original drive back in.

Author:  itm [ Sat Mar 24, 2012 9:53 pm ]
Post subject:  Re: Update failed NOK (Code 207)

I'm getting the same problem trying to re-install the firmware on a new HDD. Did you ever manage to resolve this?

Author:  chucklezt [ Mon Mar 26, 2012 12:35 am ]
Post subject:  Re: Update failed NOK (Code 207)

Unfortunately not.. still get white screen and errors. Been sitting in a drawer since.

Author:  morfanem [ Sun Apr 01, 2012 10:37 pm ]
Post subject:  Re: Update failed NOK (Code 207)

Same problem here, any good?

Author:  anony-mouse [ Thu May 24, 2012 11:39 pm ]
Post subject:  Re: Update failed NOK (Code 207)

Code 207 is issued by aosparser when the .aos upgrade file doesn't
pass the signature check.

This is confusing as I've pulled apart the aosparser in the 1.7.22-patched
.aos package and the check is *definitely* patched out (CMP R0,#0 has
been patched to MOV R0,#0).

So, somehow, this means that the recovery image in flash has been
reverted to a non-patched version :-(

There's more bad news... If the genuine original .aos files are also
giving the same error it means the signing keystore may also have been
damaged.

In theory, this means the whole device is irrecoverable.... however I've
been doing some thinking about it...
Referring to TI document SPRUF98W (OMAP35x TRM) and
Referring to TI document SPRS507F (OMAP35x Datasheet)

The OMAP3525 boots in a mode called "Fast XIP" which basically means
that the internal OMAP boot ROM *almost* immediately jumps to the beginning
of the 28F320W18 flash chip. This is shown in step 2 of Figure 25-8.
HOWEVER, Table 25-3 seems to indicate that "step 2" above is an over
simplification of what really happens, as row 0b11111 (Fast XIP) is followed
by a 2nd and 3rd preference. After peeking at the OMAP boot ROM, I found
that a check is made to see if the first word of Flash is either 0x00000000
or 0xFFFFFFFF. If it is, then the boot ROM assumes the Flash is broken and
it starts booting from USB or UART3 (the serial port available on the Dock).

I also happened to notice that the Flash chip is NOT mounted "POP" style
on the top the OMAP CPU but they DID use the "POP (CBB)" package
which means the connections to the Flash are easily accessible on the
top of the CPU. See here:
http://www.flickr.com/photos/[email protected]/3190177920/sizes/l/in/set-72157612461576128/

Looking at gold contacts at the bottom left quadrant of the CPU:

o o
o o
o x
o o
o o o o o o
o o o o o o

The pin I've marked as 'x' is the nCS0 and if this were temporarily pulled high
then the flash would seem to be broken the the CPU would boot over USB or
UART3. Using the "omap-u-boot-utils-pack" it should be possible to get
x-loader and uboot to run the recovery kernel but with a basic shell instead
of the recovery init script.
To do this I propose to pull the nCS0 line high with a 82ohm resistor for a
couple of seconds after power-on which shouldn't damage the CPU :-k

My main problem at the moment is powering the motherboard without the
battery connected as the CPU faces the motherboard stopping accessing
the nCS0 pin while it's powered on. Might need to solder some teeny wires
on.

If I can get back in then my first job will be to dump the corrupt flash to
find out what the heck has bricked all these units (I've seen several posts
in both the A5 and A7 forums from people who are currently in this trap)
and to see if there's any way out.

More in a couple of days... ;)

Author:  anony-mouse [ Thu Jun 14, 2012 10:57 pm ]
Post subject:  Re: Update failed NOK (Code 207)

OK, I got the orientation of the CPU wrong as the text on
the top doesn't appear to line up with the missing pin on
the bottom which denotes the orientation. I figured the
actual orientation out with a bit more probing of top balls
as you can't see underneath. The CPU is actually rotated
a further 90deg Clockwise than I thought, so nCS is
available as x and nOE as y, located in the top left:

o o o o o o
o o o x o y
o o
o o
o o

I'm seeing the nCS and nOE (and nADV) in the right places
on my 'scope and I've soldered a 100R to the 1.8v end of
a nearby capacitor and the other end is ready to be dabbed
onto nCS briefly, pulling high, during the first ROM boot stage.

I've got the board running by putting a 4v PSU onto the
battery springs, so can operate without the battery attached
and hence get to the CPU whilst it's powered. No LCD or SATA
ribbons connected but I have got the power strip and LED
connected for starting/rebooting and feedback.

I've modified my dock with a serial to USB adapter (1.8v one).
This is a standard FTDI part (TTL-232RG-VREG1V8-WE) and
hope to see the ROM boot ID come down that when I try
this in the dock when I next get time to play (in a couple of
nights time).

Author:  mediate [ Thu Jun 28, 2012 2:08 am ]
Post subject:  Re: Update failed NOK (Code 207)

Posting to let anony-mouse that there is interest in this. Any new developments on this matter are greatly appreciated and thank you for taking the time to investigate.

Unfortunately, my A5 has also fallen victim to this issue (just now, sadly :() and ... now I'm screwed to put it nicely. So repairing it in any way would be awesome.

Author:  anony-mouse [ Thu Jul 19, 2012 11:42 pm ]
Post subject:  Re: Update failed NOK (Code 207)

Finally had a bit more time to look at this.
Tonight, I tried booting the board with the nOE (or nCS0, I tried both)
line pulled high which stops it from booting but as soon I release it, it
carries on booting from Flash. :(
My guess is as the memory controller tries to pull the line low, it pulls
enough current to trigger a brown-out causing a CPU reset. I'm going
to try varying the pull-up resistor value to see if I can balance not
triggering reset with keeping the input to the Flash chip high enough
to not recognise the active low signal but I'm starting to lose hope on
this.
I did try poking around to see if any of the tracks between the CPU
and the Flash were the required signal so it could be briefly cut but
they don't appear to be on the surface :(
Won't get chance to play more until the weekend now.

Author:  nokiae50 [ Fri Aug 31, 2012 1:24 pm ]
Post subject:  Re: Update failed NOK (Code 207)

Long time since I am here.
I wanted to sell my device, was on patched 1.7.22. So did a format and put the same patched aos file and now on all aos files I get the NOK Code 207 error! I have no system, always boots to recovery. Any idea whats going wrong?

Author:  anony-mouse [ Fri Aug 31, 2012 9:00 pm ]
Post subject:  Re: Update failed NOK (Code 207)

Until I pull my finger out and get out to the electronics workshop again, I doubt there will ever be a solution.
Even if I do get mine up and working, there won't a a solution for other people that doesn't require a screwdriver and a very small soldering iron. My latest thinking is that my recent trick with pulling the nCS or nOE line may be working but the address is being held capacitively on the bus and therefore the data is reading back as something other than 0x00000000 or 0xffffffff. This is because the address and data pins are multiplexed so before reading data from the Flash the address is presented to the Flash.

Author:  mediate [ Sat Aug 17, 2013 2:20 am ]
Post subject:  Re: Update failed NOK (Code 207)

Any updates anony-mouse? Have you had any chances to work on it again?

Page 1 of 1 All times are UTC+01:00
Powered by phpBB® Forum Software © phpBB Limited
https://www.phpbb.com/