Unofficial Archos Support Forum
It is currently Fri Dec 06, 2019 11:33 pm

All times are UTC+01:00

Post new topic  Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Fri Nov 05, 2010 8:26 pm 
Archos Novice
Archos Novice

Joined: Fri Nov 05, 2010 8:21 pm
Posts: 1
ok this is not for the faint hearted but I have managed to unlock all plugins on the 705 WiFi with firmware

After trawling through these forums for literally hours I started to try different procedures and started to make progress.

I had recently done the GFT3 hack on a 605 WiFi and that runs great, all plugins active and working. I then bought a 705 WiFi after my son pinched that and was gutted when the cracks didnt work.

so I set about cracking the 705 WiFi

I will warn people though that for one I am not responsible for any damage done to your archos in any way, shape or form and before I started on this I hadn't even heard of Linux let alone dediced to use it.

So if anyone out there can come up with a better procedure, a safer one or a more efficient one then please use what info you can from my thread.

Credits time firstly though without these guys' posts, threads and answers I wouldnt have stood a chance

divx118 - sideways - grond - achillies

For some reason I cannot get the script to automatically edit the avos file. I have found the offsets for the hacks on the 705 avos.

I compared the 605 MC avos with the 605 Vanilla avos and then extracted the avos from my machine by removeing the hdd and hooking it up to a linux machine.
Once I had the image I mounted it and removed the and mounted that so I could extract the avos file.

I then searched for the binary strings that the hacks use and found the same strings in my 705 avos.

The offsets are listed as follows

# apply binary edits to avos to unlock plugins ( thanks archilles :) )

echo -ne '\xe3' | dd of="$HACKDIR"/usr/bin/avos conv=notrunc bs=1 seek=$((0x2437a7))
echo -ne '\0\0\xa0\xe3\x1e\xff\x2f\xe1' | dd of="$HACKDIR"/usr/bin/avos conv=notrunc bs=1 seek=$((0x90bec0))
echo -ne '\x01\x30\xa0\xe3' | dd of="$HACKDIR"/usr/bin/avos conv=notrunc bs=1 seek=$((0x90d044))
echo -ne '\xe3' | dd of="$HACKDIR"/usr/bin/avos conv=notrunc bs=1 seek=$((0x90d46b))
echo -ne '\0\0\0\0\0\0' | dd of="$HACKDIR"/usr/bin/avos conv=notrunc bs=1 seek=$((0x9f2344))

These are slightly different to the 605 ones. When I copied this over the ones in the script I could not get to run it kept crashing and no plugins were unlocked.

I then decided to try the edits on the actual avos file. I edited the Vanilla avos I extracted at the points listed above with the values listed. I then copied the avos file to my archos

When I ran the fileserver it didnt crash this time everything worked and I had the plugins enabled.

What I am looking for now is some way to replace the avos file on my machine with the avos I edited so the plugins would be permenantly available or some way to use to do the edits.

Can anyone help with tidying this up or making it permanent ?

PostPosted: Tue Aug 09, 2011 3:12 pm 
Archos Guru
Archos Guru

Joined: Wed Nov 21, 2007 6:41 pm
Posts: 448
Sorry this is a VERY late reply.

1. What you did is SUPERB :-)
2. It should have worked from the script.

I wonder if you edited the file in a windows editor and made it incompatible with linux? (windoze adds CR/LF to the end of each line, but linus just has a LF character)

The script checks for a version number of avos before it applies the edits, make sure you have 2.1.04 currently installed.

Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 2 posts ] 

All times are UTC+01:00

Who is online

Users browsing this forum: No registered users and 4 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited