Unofficial Archos Support Forum
It is currently Tue Feb 18, 2020 9:13 pm

All times are UTC+01:00

Post new topic  Reply to topic  [ 2 posts ] 
Author Message
 Post subject: New 404 doesnt power up?
PostPosted: Tue Jun 19, 2007 2:35 pm 
Hi guys

just joined after browsing the forum, looks like a good place :)

I have a query, i hope im not duplicating anything already answered although i couldnt find the answer to my question.

Just got a 404, plugged it into my laptop and left for two hours - nothing - no charge light lit up and no response to power button or reset button.

Tried leaving on trickle on my work pc overnight but no change.

Also purchased an ac power adaptor but still no response.

Am i missing something or is there a genuine fault?

Hope ive missed something simple rather then have to send it back to amazon!

Any help appreciated, kind regs


 Post subject:
PostPosted: Wed Jun 20, 2007 12:20 am 
Archos User
Archos User

Joined: Wed Feb 07, 2007 12:56 am
Posts: 147
Sounds like you got a dud

A2 defect.

Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 2 posts ] 

All times are UTC+01:00

Who is online

Users browsing this forum: No registered users and 4 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited