Forum.ArchosFans.com
Archos 80 G9 1.5Ghz 1GB RAM ICS 8GB: Buy now (free shipping)
Archos 80 G9 1.5Ghz 1GB RAM ICS 250GB: Buy now (free shipping)
Archos 101 G9 1.5Ghz 1GB RAM ICS 8GB: Buy now (free shipping)
Archos 101 G9 1.5Ghz 1GB RAM ICS 250GB: Buy now (free shipping)
 * Register    * Login 

It is currently Wed Oct 01, 2014 3:14 pm

All times are UTC + 1 hour



Post new topic  Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Sun Dec 30, 2012 1:22 am 
Offline
Archos Novice
Archos Novice

Joined: Sun Dec 30, 2012 12:42 am
Posts: 8
Greetings: I just brought a 604 (model 42518). It came with the USB cable (it locks into the slightly shorter and wider slot on the bottom). I cannot seem to charge the unit. I plug the cable into the computer and the unit will work (it won't stay on for long), but the "chg" light will not come on. I have tried resetting the unit (under the Battery--BTW-does the unit need to be plugged in during reset?), still not working. How long should I keep it plugged in before I will know if the battery is any good? Also, can I use an AC usb connector for charging?

Thanks in advance, and I look forward to getting my 604 running.


Top
   
 
PostPosted: Sun Dec 30, 2012 3:23 pm 
Offline
Archos User
Archos User

Joined: Thu Jan 07, 2010 10:39 pm
Posts: 137
Yes, a usb charger will work, (most are 500mA usb spec, you can get ~ or >1A ones and these are better for larger archos units) try some different usb sockets if available - the charge light should come on.
If no charge light the current is probably not getting through to the battery. Older archos's had a surface mount fuse soldered to the board and when this blew it gave the same symptoms. Only solution was to open it up and follow the volts in with a meter, don't know if the 604 is the same but it might be a good bet.


Top
   
 
PostPosted: Sun Dec 30, 2012 6:54 pm 
Offline
Archos Novice
Archos Novice

Joined: Sun Dec 30, 2012 12:42 am
Posts: 8
Thanks fredc:
I left it hooked up to my laptop USB last night. The battery level indicator read about half way before bedtime, this morning, the same. I disconnected the usb then battery level dropped to practically zero. This morning I plugged the usb into an iPhone wall usb connector, no charge light. What would it take to fix the board?
Thanks Again.


Top
   
 
PostPosted: Wed Jan 02, 2013 9:10 am 
Offline
Archos Novice
Archos Novice

Joined: Sun Dec 30, 2012 12:42 am
Posts: 8
I have returned the player.... I brought a 605 off Ebay and am now having charging problems with that! See ya over at that board. :(


Top
   
 
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 4 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Hosted by Forumatic™